Bug 184063 - undefined symbol: alutInit
Summary: undefined symbol: alutInit
Status: CLOSED DUPLICATE of bug 181915
Alias: None
Product: Fedora
Classification: Fedora
Component: openal   
(Show other bugs)
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-05 20:09 UTC by James Sturgis
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-05 23:44:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description James Sturgis 2006-03-05 20:09:02 UTC
Description of problem:
this happened to me too:
===============
Scot L. Harris wrote:


I found the openal package in FC Extras.

openal-0.0.9-0.2.20060204cvs.fc4

...

./X-Plane-i586: symbol lookup error: ./X-Plane-i586: undefined symbol:
alutInit

Running the following command on the libopenal.so.0.0 library seems to
indicate that the symbols have been stripped.

nm /usr/lib/libopenal.so.0.0.0
nm: /usr/lib/libopenal.so.0.0.0: no symbols

Which would seem to explain the undefined symbol for alutInit.

Because the debugging info has been stripped.


Is there a reason this library was built this way?

$ yum install openal-debuginfo
=====================================
Version-Release number of selected component (if applicable): 0.0.9-0.4.2
I tried to install openal-debuginfo as above but my system does not show
a 0.0.9-0.4.2, just the previous version:
openal-debuginfo.i386      0.0.8-1.2.fc4.rf       installed.

My previous openal installation worked with the same X-Plane software that now
fails.


How reproducible: 100%


Steps to Reproduce:
1. cd to X-Plane\ 8.20 subdirectory
2. ./X-Plane-athlon-xp
3. result is:
[root@flight X-Plane 8.20]# ./X-Plane-athlon-xp
./X-Plane-athlon-xp: symbol lookup error: ./X-Plane-athlon-xp: undefined symbol:
alutInit
[root@flight X-Plane 8.20]#



  
Actual results:


Expected results:


Additional info:

Comment 1 Michael Schwendt 2006-03-05 23:44:14 UTC

*** This bug has been marked as a duplicate of 181915 ***


Note You need to log in before you can comment on or make changes to this bug.