Bug 184065 - Slave files placed in wrong directory - permission prevents zone transfer
Slave files placed in wrong directory - permission prevents zone transfer
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-bind (Show other bugs)
rawhide
noarch Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Brich
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-05 15:36 EST by Chris Tyler
Modified: 2008-04-29 07:34 EDT (History)
0 users

See Also:
Fixed In Version: system-config-bind-4.0.0-40
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-29 07:34:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Tyler 2006-03-05 15:36:42 EST
Description of problem:
1. By default, slave zone files are placed in /var/named (or
/var/named/cache/var/named if bind-chroot is installed)
2. /var/named is owned by root:named with permission 0750 so the zone transfer
fails because the slave zone file cannot be opened
3. According to bug 184035, slave zones should be placed in /var/named/slave,
which is owned by named:named

Version-Release number of selected component (if applicable):
 system-config-bind-4.0.0-36_FC5

Steps to Reproduce:
1. Create a slave zone for a valid master.
2. Save the configuration.
  
Actual results:
- Zone does not transfer
- Error messages indicating that the slave zone file can't be opened (created)
are found in /var/log/messages

Expected results:
- The zone should transfer

Additional info:
Solution:
prepend 'slave/' to the name of slave zone files
Comment 1 Jason Vas Dias 2006-03-06 09:45:17 EST
Yes, you're right - s-c-b should prompt users to prepend 'slaves/' to the location
of slave or DDNS updateable zone files - the next version (s-c-b-4.0.0-40) will
do this - thanks.
Comment 2 Jason Vas Dias 2006-03-08 17:12:07 EST
This bug is now fixed with system-config-bind-4.0.0-40_FC5, available from:
  http://people.redhat.com/~jvdias/system-config-bind

When you add a slave zone, the default zone file is now prefixed with slaves/,
and you will be warned if you create a slave zone file not in slaves/ .
When you make a zone dynamically updateable by adding an 'allow-update' clause,
the GUI will prompt to be allowed to move the zone file to slaves/ .
Comment 3 Fedora Update System 2006-03-08 18:52:31 EST
From User-Agent: XML-RPC

system-config-bind-4.0.0-40_FC4 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 4 petrosyan 2008-02-16 18:46:11 EST
Can anybody reproduce this bug in Fedora 8?
Comment 5 Radek Brich 2008-04-29 07:34:01 EDT
This seems fixed in current version. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.