Bug 1840661 - DataVolume import progress in activity always points to VM, but the DV owner can be VMI and VMT as well
Summary: DataVolume import progress in activity always points to VM, but the DV owner ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.4
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.5.0
Assignee: Rastislav Wagner
QA Contact: Radim Hrazdil
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-27 12:11 UTC by Radim Hrazdil
Modified: 2020-07-13 17:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Disk import activity always expects that owner resource is VM but it can also be VMT or VMI Consequence: VM resource link points to 404 if the owner of disk import activity is VMT or VMI Fix: Properly check the owner resource of disk import activity Result: Resource link points to VM, VMT, or VMI based on the owner resource
Clone Of:
Environment:
Last Closed: 2020-07-13 17:42:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5599 None closed Bug 1840661: VM Disk import may be owned by VMT and VMI also 2020-07-02 19:49:36 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:42:26 UTC

Description Radim Hrazdil 2020-05-27 12:11:35 UTC
Description of problem:


Version-Release number of selected component (if applicable):
4.5

How reproducible:
100%

Steps to Reproduce:
1. Create a VirtualMachine Template/VMI with a DV that needs to be imported.
2. Navigate to Overview to see the progress.

Actual results:
The resource always has a badge of a VM, and link leads to virtual machine, even when the resource is i.e. a Virtual Machine Template

Expected results:
Link should point to the correct resource kind

Comment 3 Radim Hrazdil 2020-05-28 11:17:49 UTC
Verified

Comment 4 errata-xmlrpc 2020-07-13 17:42:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.