Bug 184071 - [x86_64] 32bit OpenOffice file chooser missing gnome-vfs connection.
[x86_64] 32bit OpenOffice file chooser missing gnome-vfs connection.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-05 16:56 EST by Gian Paolo Mureddu
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-27 15:12:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gian Paolo Mureddu 2006-03-05 16:56:00 EST
Description of problem:
OpenOffice applications no longer show other devices or mounted shares on the
open/save dialogs after last update.

Version-Release number of selected component (if applicable):
OpenOffice.org-2.0.1.1-5.1

How reproducible:
Always.

Steps to Reproduce:
1. Insert an USB drive stick, GNOME will mount it.
2. Open any OpenOffice application and click the open icon on the tool bar. 
3. In the dialog box, on the left panel, notice the absense of the USB drive
icon. The device is still available from its mount point, though.

Actual results:
Missing extended devices such GNOME-VFS mounted shares (through means of
places-->Connect to server), renders lesser usability, and a regression.

Expected results:
This was not the case with the last verion prior to the latest update to OOo in FC4

Additional info: A couple screenshots comparing Gedit's Open dialog and OOo's
Open dialog:

Gedit:
http://img.photobucket.com/albums/v328/thetargos/Desktop/gedit-open.png

OOo:
http://img.photobucket.com/albums/v328/thetargos/Desktop/OOo-open.png
Comment 1 Caolan McNamara 2006-03-06 05:13:24 EST
strange, they looks the same for me, both having the same contents. I see that
your "file system" icon is also different between the two applications. 

How about in mozilla's file open dialog. Is mozilla like gedit, or like your
openoffice.org ?
Comment 2 Gian Paolo Mureddu 2006-03-07 01:14:59 EST
Mozilla's (Firefox) Open dialog looks like this:

http://img.photobucket.com/albums/v328/thetargos/Desktop/FF-Open.png

Mozilla SeaMonkey's looks exactly the same.


On my Laptop, though (same OOo major version, but with concurrent appearance of
2.0.1.1-4.1 in the RPM database), it looks as Gedit's, though... Updated it
yesterday just to see if it was an issue of 2.0.1.1-5.1 (and ended up with
duplicates in rpmdb). To note is this: I first thought this was the same on my
main machine and my laptop, as both use FC4, only my WS is x86_64 and the laptop
is i686; but since OOo packages are i386 for both platforms, I may have assumed
too much.
Comment 3 Caolan McNamara 2006-03-07 06:53:06 EST
Indeed, as OOo is 32bit on x86_64 it uses the i386 stack which is different to
the x86_64 one. I bet that if you run any 32bit app (e.g. the 32bit mozilla)
which uses the gnome filechooser and the gnome-vfs stack that the results will
be the same in OOo as in any other 32bit app. Or if you revert to the older OOo
that there is no change.

Did it use to work with 32bit OOo on x86_64 ? and I assume you didn't remove any
relevent i386 libs ?
Comment 4 Gian Paolo Mureddu 2006-03-07 13:10:24 EST
Not I am aware of, I have all pertinent libraries installed and in place... I'll
run a quick check of gnome-vfs and other gnome packages, alas I don't remember
seeing such packages for i386 on the base or extras repositories.

What libraries should I be looking for as the required 32-bit ones?
Comment 5 Gian Paolo Mureddu 2006-03-26 13:16:33 EST
For what is worth, this problem persists with Fedora Core 5 x86_64 and the
32-bit OpenOffice.org 2.0.2 packages.
Comment 6 Matthias Clasen 2006-07-27 15:12:30 EDT
OOo has a 64-bit build now, so this can probably be closed, right ?
Comment 7 Gian Paolo Mureddu 2006-07-28 00:02:54 EDT
Is this build for Core 5 or Core 6 test? 

Note You need to log in before you can comment on or make changes to this bug.