Bug 1840720 - Installing or Uninstalling helm chart flickers the topology page with +Add page cards
Summary: Installing or Uninstalling helm chart flickers the topology page with +Add pa...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Jeff Phillips
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-27 13:42 UTC by Jeff Phillips
Modified: 2020-07-13 17:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Version: 4.5.0-0.nightly-2020-05-27-000432 Cluster ID: a258d5da-ffc1-4a0e-81c5-65368b7f8b8a Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.61 Safari/537.36
Last Closed: 2020-07-13 17:42:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5601 0 None open Bug 1840720: Fix for updates of Helm charts in topology 2020-06-24 03:27:02 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:42:26 UTC

Description Jeff Phillips 2020-05-27 13:42:12 UTC
Description of problem:

Installing or Uninstalling helm chart flickers the topology page with +Add page cards when there are only helm charts in the project. If there are other workloads, the existing helm releases disappear then reappear after a moment.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install several helm charts from UI or CLI
2. Navigate to the Topology page.
2. Uninstall one of the helm charts via the right click action on a chart.

Actual results:

Helm charts disappear, then return

Expected results:

The uninstalled helm chart is removed.

Additional info:

Comment 3 Gajanan More 2020-05-28 05:55:54 UTC
I have validated the bugzilla on:
Build: 4.5.0-0.nightly-2020-05-27-202943
Browser: Google Chrome Version 81.0.4044.129
Marking this as verified.

Comment 4 errata-xmlrpc 2020-07-13 17:42:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.