Bug 184076 - powermanga crashing when reaching level 35 boss
powermanga crashing when reaching level 35 boss
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: powermanga (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-05 18:05 EST by Hugo Cisneiros
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-11 12:52:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb output of the crash (1.68 KB, text/plain)
2006-03-06 20:23 EST, Hugo Cisneiros
no flags Details
gdb output of the crash (compiled version) (1.29 KB, text/plain)
2006-03-07 11:16 EST, Hugo Cisneiros
no flags Details

  None (edit)
Description Hugo Cisneiros 2006-03-05 18:05:46 EST
Description of problem:

After reaching level 35 boss (10th boss), powermanga crashes, sending a
Segmentation fault.

Version-Release number of selected component (if applicable):

powermanga-0.79-6.fc4

How reproducible:

Get to level 35 boss. If you're having difficults with this, you can try
executing with the following command-line parameters:

powermanga --verbose --easy

This will generate verbose messages at the console and provide an easy way (many
extras) to reach the level 35.
  
Expected results:

Finish the game passing level 35 :-)
Comment 1 Hugo Cisneiros 2006-03-06 16:40:24 EST
I compiled it from the upstream source, got to level 35 and the problem
persists. I'll try later with another distribution to see if this is an upstream
problem only, or if it's a fedora problem.
Comment 2 Hugo Cisneiros 2006-03-06 20:23:02 EST
Created attachment 125741 [details]
gdb output of the crash

Here is the gdb output of the crash. Maybe some sprite file is missing?
Comment 3 Matthias Saou 2006-03-07 07:11:50 EST
Thanks for taking the time to investigate the problem. And let me know if you
find anything that could fix the problem.
Comment 4 Hugo Cisneiros 2006-03-07 11:16:30 EST
Created attachment 125762 [details]
gdb output of the crash (compiled version)

This is another gdb output of the crash. This time, I used the compiled version
instead of the rpm package from fedora extras. It gives a similar, but
different error.
Comment 5 Hugo Cisneiros 2006-03-07 13:09:21 EST
Tried with Debian, same version, and it worked (I passed the level 35 without
segmentation fault). I think the problem is with Fedora or some of its
libraries... :(
Comment 6 Hugo Cisneiros 2006-03-22 16:23:59 EST
Now I updated to FC5 and the problem still persists. Later I'll try running with
another user.

Version-Release number of selected component (if applicable):

powermanga-0.79-8.fc5
Comment 7 Hugo Cisneiros 2006-03-22 16:38:09 EST
Re-opened the bug because of a mistake while reporting the bug. Sorry.
Comment 8 Bruno Ethvignot 2006-03-26 11:14:06 EST
Please try this new version and report any problems: 
http://linux.tlk.fr/powermanga-0.80.tgz

./configure
make
./powermanga --window
Comment 9 Hugo Cisneiros 2006-03-26 15:43:30 EST
Upstream have made this new version (0.80) with the fix and it worked very fine.
Now we need to re-package with the new version. This is with you Matthias :) If
you need any help from me, I'll be glad to do it. Thanks.
Comment 10 Matthias Saou 2006-03-27 03:31:10 EST
0.80 doesn't seem to be available from the website nor as a direct download yet.
Can you please tell me once it's available so that I can update the packages?
Comment 11 Hugo Cisneiros 2006-03-27 07:28:02 EST
The page was not updated, but the file is available at the same website as the
other official versions. As the comment #8 stated:

http://linux.tlk.fr/powermanga-0.80.tgz

I made contact with upstream and Bruno Ethvignot replied me with this new
version and fix. I think the page will be updated soon with the new version, so
you can package the file as well, or wait some more time. If you have any doubts
on this the best way is to contact the developers in its site. Thanks.
Comment 12 Matthias Saou 2006-04-11 12:52:43 EDT
I've pushed out 0.80 packages for FC3, FC4, FC5 and FC devel at last.
Comment 13 Hugo Cisneiros 2006-04-11 13:13:42 EDT
Thank you Matthias!
Comment 14 Matthias Saou 2006-04-21 07:56:15 EDT
Just worth pointing out that the 0.80-1 packages are totally broken...
The "make install" in 0.80 doesn't install the *.txt files from the "texts"
directory, and the game refuses to run without them. See bug #188901.

Note You need to log in before you can comment on or make changes to this bug.