Bug 1840760 - Monitoring tabs in dev console should be hidden if monitoring is disabled
Summary: Monitoring tabs in dev console should be hidden if monitoring is disabled
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.5.0
Assignee: Rohit Rai
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-27 14:49 UTC by Rohit Rai
Modified: 2020-07-13 17:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:42:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5602 0 None closed Bug 1840760: Hide monitoring tabs when monitoring is disabled 2020-07-03 10:08:45 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:42:26 UTC

Description Rohit Rai 2020-05-27 14:49:35 UTC
Description of problem:When the monitoring operator is missing, the monitoring nav item should still be shown, but unavailable tabs should be hidden (dashboards, metrics, etc). Events and any other usable tabs should still be visible.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Disable monitoring
2. Go to monitoring nav in dev console


Actual results:
Dashboards and metrics tabs are visible but do not work.

Expected results:
Dashboards and metrics tabs should be hidden.

Additional info:

Comment 3 Gajanan More 2020-06-11 09:48:24 UTC
Marking this as verified as disabling monitoring operator is not possible and it's a edge case.

Comment 4 errata-xmlrpc 2020-07-13 17:42:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.