Bug 1840766 - cannot create VM with disks again with the same name
Summary: cannot create VM with disks again with the same name
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.0
Assignee: Phillip Bailey
QA Contact: Guohua Ouyang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-27 14:53 UTC by Filip Krepinsky
Modified: 2020-10-27 16:01 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:01:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5618 0 None closed Bug 1840766: Autogenerate data volume names 2020-10-08 08:15:25 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:01:21 UTC

Description Filip Krepinsky 2020-05-27 14:53:52 UTC
How reproducible:
100


Steps to Reproduce:
1. create VM with http / attach cloned disk source
2. delete the VM and uncheck Delete Disks
3. create the same VM (you can change things like http source) with the same name again


Actual results:

the VM returns an error: Failed to create DataVolume: admission webhook "datavolume-validate.cdi.kubevirt.io" denied the request: Destination PVC already exists

Expected results:
The VM gets and DVs get created and can start sucessfully 

Additional info:

We should generateName for all of our dataVolumes (also for example in clone-modal, etc.)

Comment 3 Guohua Ouyang 2020-07-02 03:07:38 UTC
Could reproduce the issue on 4.5.0-rc.4 and verified it on remotes/upstream/release-4.6(commit 5d355c87839fca0cec4a012434ce3826ea3280f8).

Comment 5 errata-xmlrpc 2020-10-27 16:01:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.