Bug 1840861 - Charts in the Node Details tab duplicate information found in the Node Overview tab
Summary: Charts in the Node Details tab duplicate information found in the Node Overvi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.5.0
Assignee: Rastislav Wagner
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-27 18:05 UTC by Andy Braren
Modified: 2020-07-13 17:42 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:42:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5614 0 None open Bug 1840861: Remove charts from Node Details 2020-06-24 03:27:40 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:42:37 UTC

Description Andy Braren 2020-05-27 18:05:57 UTC
Description of problem:

The new Node Overview's Utilization card was intended to replace the charts that appear in the Details tab, since it includes more information about limits/requests and available resources and is consistent with Cluster/Project/Host Overviews. The charts in the Details tab haven't been removed yet.

Version-Release number of selected component (if applicable):
4.5

How reproducible:
Navigate to Compute > Nodes > Node Details. The Overview tab's Utilization card has more information than the charts at the top of the Details tab.

Steps to Reproduce:
1. Navigate to a Node Details page
2. Compare the charts shown in the Overview and Details tabs

Actual results:
The Details tab has charts for CPU/Memory/Pods/Network/Filesystem.

Expected results:
The Details tab shouldn't have those charts now that the Node Overview exists.

Additional info:

Comment 3 Yanping Zhang 2020-06-01 10:12:45 UTC
Checked on OCP 4.5 cluster with payload 4.5.0-0.nightly-2020-05-30-025738
Go to one node page, all charts are shown under "Overview" page, and check under "Details" tab, there is no metrics chart now.

Comment 4 errata-xmlrpc 2020-07-13 17:42:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.