Bug 1840865 - Review Request: lv2lint - LV2 turtle language checker
Summary: Review Request: lv2lint - LV2 turtle language checker
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Vasiliy Glazov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: FE-NEEDSPONSOR
TreeView+ depends on / blocked
 
Reported: 2020-05-27 18:18 UTC by ycollet
Modified: 2020-12-12 21:32 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-12-12 21:32:19 UTC
Type: ---
vascom2: fedora-review+


Attachments (Terms of Use)
The spec file (1.45 KB, text/plain)
2020-05-27 19:06 UTC, ycollet
no flags Details
A requested patch (608 bytes, application/mbox)
2020-05-27 19:06 UTC, ycollet
no flags Details

Description ycollet 2020-05-27 18:18:57 UTC
Spec URL: https://github.com/ycollet/fedora-spec/blob/master/lv2lint/lv2lint.spec
SRPM URL: https://download.copr.fedorainfracloud.org/results/ycollet/linuxmao/fedora-32-x86_64/01345080-lv2lint/lv2lint-0.2.0-3.fc32.src.rpm
Description: LV2 turtle language checker
Fedora Account System Username: ycollet

This program allow to check the language of ttl files in LV2 plugins.
To test:

install lv2lint + lv2-amsynth

And then:

lv2lint http://code.google.com/p/amsynth/amsynth

You can obtain URI (URL of the LV2 plugin) using lv2ls.

Comment 1 Vasiliy Glazov 2020-05-27 18:34:00 UTC
1. Remove
%global debug_package %{nil}

2. Add
%{set_build_flags}
at begin of %build section.

3. Change
%setup -qn lv2lint-%{version}
to
%autosetup

4. Remove BuildRoot string.

5. Spec URL must be to raw text.

It is not all mistakes.

Comment 2 ycollet 2020-05-27 19:06:08 UTC
Created attachment 1692808 [details]
The spec file

Comment 3 ycollet 2020-05-27 19:06:29 UTC
Created attachment 1692809 [details]
A requested patch

Comment 4 ycollet 2020-05-27 19:06:52 UTC
I just fixed the spec file.
I added a patch because of a duplicated symbol problem on Fedora 32.

I don't understand the point 5 ? 
In the Review request, I must add the spec file and not give an URL to the spec file ?
In the review request template, an URL is indicated in the spec field.

I use rpmlint on the spec file and 0 error / 0 warnings are reported.

Thanks for the %autosetup, and for the %set_build_flags too.

Comment 5 Vasiliy Glazov 2020-05-27 19:23:43 UTC
No need patches here put it near your spec file. If you added patch then need
%autosetup -p1

URL should be this https://raw.githubusercontent.com/ycollet/fedora-spec/master/lv2lint/lv2lint.spec

You still not removed BuildRoot.

6. Instead of
VERBOSE=1 meson --buildtype release --prefix=/usr build
you should use macro 
%meson
%meson_build

Then %{set_build_flags} not needed.

Comment 6 Vasiliy Glazov 2020-05-27 19:28:07 UTC
7. Change License: field to
Artistic 2.0

Here you can find all allowed licenses and how they must be writed in License: field
https://fedoraproject.org/wiki/Licensing:Main?rd=Licensing#SoftwareLicenses

Comment 7 Vasiliy Glazov 2020-05-27 19:36:30 UTC
8. Don't use glob * in %files section such way.
Change paths to something like
%{_bindir}/{name}*
%{_mandir}/man1/%{name}.1*

Comment 8 ycollet 2020-05-27 19:44:13 UTC
OK, Thanks.
I updated the build / install part. I removed %{set_build_flags} and used %meson %meson_build and %meson_install.
I replaced the license by Artistic 2.0 and I fixed the %file part by using %{name}.

Comment 9 Vasiliy Glazov 2020-05-27 19:47:36 UTC
Now please post direct links to updated Spec URL: and SRPM URL:

Comment 11 Vasiliy Glazov 2020-05-27 19:55:51 UTC
Just use
Spec URL: ...
SRPM URL: ...
As in first message.

And you still not removed BuildRoot string from spec!

Comment 12 ycollet 2020-05-27 20:20:56 UTC
Ah, sorry. I thought you where talking about the %buildroot in the build and install section.
I commit a change ASAP.

Comment 13 Vasiliy Glazov 2020-05-27 20:24:41 UTC
Now post new URLs. It needed to make review.

Comment 14 ycollet 2020-05-27 20:28:35 UTC
I was waiting for the build to finish on COPR.

The link to the lv2lint spec file on the COPR repo:
https://download.copr.fedorainfracloud.org/results/ycollet/linuxmao/fedora-32-x86_64/01414998-lv2lint/lv2lint.spec

The link to the corresponding src rpm package:
https://download.copr.fedorainfracloud.org/results/ycollet/linuxmao/fedora-32-x86_64/01414998-lv2lint/lv2lint-0.2.0-4.fc32.src.rpm

Comment 15 Vasiliy Glazov 2020-05-27 20:44:57 UTC
It is really need gcc-c++ to build? I don't see it in build.log
If not then remove it from BuildRequires.

Source0: https://gitlab.com/drobilla/lv2lint/-/archive/%{version}/lv2lint-%{version}.tar.gz
can be changed to
Source0: %{url}/-/archive/%{version}/lv2lint-%{version}.tar.gz

Comment 16 ycollet 2020-05-27 20:54:25 UTC
Yes, you're right, c++ was not required. I cleaned up the spec file.

The URL to  the last version of the spec file: 
https://download.copr.fedorainfracloud.org/results/ycollet/linuxmao/fedora-32-x86_64/01415006-lv2lint/lv2lint.spec

The URL to the last src rpm file:
https://download.copr.fedorainfracloud.org/results/ycollet/linuxmao/fedora-32-x86_64/01415006-lv2lint/lv2lint-0.2.0-4.fc32.src.rpm

Comment 17 Vasiliy Glazov 2020-05-27 21:15:50 UTC
Approved.

Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
[ ] = Manual review needed



===== MUST items =====

C/C++:
[x]: Package does not contain kernel modules.
[x]: Package contains no static executables.
[x]: If your application is a C or C++ application you must list a
     BuildRequires against gcc, gcc-c++ or clang.
[x]: Header files in -devel subpackage, if present.
[x]: Package does not contain any libtool archives (.la)
[x]: Rpath absent or only used for internal libs.

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses
     found: "Unknown or generated", "Artistic License (v2.0)", "*No
     copyright* Public domain", "BSD 3-clause "New" or "Revised" License".
     15 files have unknown license. Detailed output of licensecheck in
     /home/vascom/1840865-lv2lint/licensecheck.txt
[x]: License file installed when any subpackage combination is installed.
[x]: %build honors applicable compiler flags or justifies otherwise.
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Useful -debuginfo package or justification otherwise.
[x]: Package is not known to require an ExcludeArch tag.
[x]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 10240 bytes in 3 files.
[x]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.
[x]: Package requires other packages for directories it uses.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package must not depend on deprecated() packages.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package does not use a name that already exists.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
[!]: Sources can be downloaded from URI in Source: tag
     Note: Could not download Source0:
     https://gitlab.com/drobilla/lv2lint/-/archive/0.2.0/lv2lint-0.2.0.tar.gz
     See: https://docs.fedoraproject.org/en-US/packaging-
     guidelines/SourceURL/
[-]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[x]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[x]: Patches link to upstream bugs/comments/lists or are otherwise
     justified.
[x]: SourceX tarball generation or download is documented.
     Note: Package contains tarball without URL, check comments
[-]: Sources are verified with gpgverify first in %prep if upstream
     publishes signatures.
     Note: gpgverify is not used.
[x]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[-]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed
     files.
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Fully versioned dependency in subpackages if applicable.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on debuginfo package(s).
     Note: No rpmlint messages.
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Large data in /usr/share should live in a noarch subpackage if package
     is arched.
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: lv2lint-0.2.0-4.fc33.x86_64.rpm
          lv2lint-debuginfo-0.2.0-4.fc33.x86_64.rpm
          lv2lint-debugsource-0.2.0-4.fc33.x86_64.rpm
          lv2lint-0.2.0-4.fc33.src.rpm
lv2lint.x86_64: W: spelling-error %description -l en_US sord -> chord, sod, sword
lv2lint.x86_64: W: manual-page-warning /usr/share/man/man1/lv2lint.1.gz 40: warning: macro `/.HP' not defined
lv2lint.x86_64: W: manual-page-warning /usr/share/man/man1/lv2lint.1.gz 41: a special character is not allowed in a name
lv2lint.x86_64: W: manual-page-warning /usr/share/man/man1/lv2lint.1.gz 41: warning: macro `/' not defined
lv2lint.x86_64: W: manual-page-warning /usr/share/man/man1/lv2lint.1.gz 42: warning: macro `/.IP' not defined
lv2lint.x86_64: W: manual-page-warning /usr/share/man/man1/lv2lint.1.gz 43: warning: macro `/Run' not defined
lv2lint.x86_64: W: manual-page-warning /usr/share/man/man1/lv2lint.1.gz 46: a special character is not allowed in a name
lv2lint.x86_64: W: manual-page-warning /usr/share/man/man1/lv2lint.1.gz 48: warning: macro `/Create' not defined
lv2lint.x86_64: W: manual-page-warning /usr/share/man/man1/lv2lint.1.gz 51: a special character is not allowed in a name
lv2lint.x86_64: W: manual-page-warning /usr/share/man/man1/lv2lint.1.gz 53: warning: macro `/Custom' not defined
lv2lint.src: W: spelling-error %description -l en_US sord -> chord, sod, sword
4 packages and 0 specfiles checked; 0 errors, 11 warnings.




Rpmlint (debuginfo)
-------------------
Checking: lv2lint-debuginfo-0.2.0-4.fc33.x86_64.rpm
1 packages and 0 specfiles checked; 0 errors, 0 warnings.





Rpmlint (installed packages)
----------------------------
warning: Found bdb Packages database while attempting sqlite backend: using bdb backend.
warning: Found bdb Packages database while attempting sqlite backend: using bdb backend.
lv2lint.x86_64: W: spelling-error %description -l en_US sord -> chord, sod, sword
lv2lint.x86_64: W: invalid-url URL: https://gitlab.com/drobilla/lv2lint <urlopen error [Errno -2] Name or service not known>
warning: Found bdb Packages database while attempting sqlite backend: using bdb backend.
lv2lint-debugsource.x86_64: W: invalid-url URL: https://gitlab.com/drobilla/lv2lint <urlopen error [Errno -2] Name or service not known>
warning: Found bdb Packages database while attempting sqlite backend: using bdb backend.
lv2lint-debuginfo.x86_64: W: invalid-url URL: https://gitlab.com/drobilla/lv2lint <urlopen error [Errno -2] Name or service not known>
3 packages and 0 specfiles checked; 0 errors, 4 warnings.



Requires
--------
lv2lint (rpmlib, GLIBC filtered):
    libc.so.6()(64bit)
    libdl.so.2()(64bit)
    liblilv-0.so.0()(64bit)
    rtld(GNU_HASH)

lv2lint-debuginfo (rpmlib, GLIBC filtered):

lv2lint-debugsource (rpmlib, GLIBC filtered):



Provides
--------
lv2lint:
    lv2lint
    lv2lint(x86-64)

lv2lint-debuginfo:
    debuginfo(build-id)
    lv2lint-debuginfo
    lv2lint-debuginfo(x86-64)

lv2lint-debugsource:
    lv2lint-debugsource
    lv2lint-debugsource(x86-64)



Generated by fedora-review 0.7.5 (5fa5b7e) last change: 2020-02-16
Command line :/usr/bin/fedora-review -b 1840865
Buildroot used: fedora-rawhide-x86_64
Active plugins: Generic, Shell-api, C/C++
Disabled plugins: Haskell, fonts, Python, PHP, Perl, R, Java, Ocaml, SugarActivity
Disabled flags: EPEL6, EPEL7, DISTTAG, BATCH, EXARCH

Comment 18 Vasiliy Glazov 2020-05-27 21:16:30 UTC
Now you need to get sponsored.
https://fedoraproject.org/wiki/Join_the_package_collection_maintainers#Get_Sponsored

Comment 19 ycollet 2020-05-27 21:21:26 UTC
OK, thanks a lot for your review.
I will now try to find a sponsor.

Comment 20 Vasiliy Glazov 2020-05-27 21:22:35 UTC
I can be a sponsor.

Comment 21 ycollet 2020-05-28 09:40:40 UTC
I finished reading the wiki page related to sponsoring.
What can I do so as you sponsor me ?

Comment 22 Vasiliy Glazov 2020-05-28 09:51:39 UTC
Because your spec was not good at start I need to make sure you understand most significant rules of Fedora packaging guidellines.
https://docs.fedoraproject.org/en-US/packaging-guidelines/

First variant - you can make few reviews for other packages in bugzilla.
Second variant - as I understand you want to add more packages from your copr. So you can make 2-4 new review requests for it with good specs at start (not ideally, I anderstand that you beginner, but without big mistakes).

Comment 23 ycollet 2020-05-28 09:53:57 UTC
OK. I will certainly try to do a mix: submitting some new spec files and try to do some review.
When I do a review, I add you to the review ?

Comment 24 Vasiliy Glazov 2020-05-28 10:29:24 UTC
Yes, inform me.

Comment 25 ycollet 2020-11-24 19:18:32 UTC
Package review opened more than 5 months ago.

Nobody seems to be interested ...
So, I close the package review.
Somebody else will had back this if somebody at fedora is interested.


Note You need to log in before you can comment on or make changes to this bug.