Bug 1840940 - Notification drawer not displaying upgrade message
Summary: Notification drawer not displaying upgrade message
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Joe Caiani
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-28 00:09 UTC by Joe Caiani
Modified: 2020-07-13 17:42 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: clusterVersion not fetched correctly Consequence: no upgrade messaging in notification drawer Fix: update fetch of clusterversion object Result: verified cluster upgrade messages appear in notification drawer
Clone Of:
Environment:
Last Closed: 2020-07-13 17:42:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5611 0 None closed Bug 1840940: Fix notification drawer to display cluster version upgrade messaging 2020-06-24 03:27:44 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:42:37 UTC

Description Joe Caiani 2020-05-28 00:09:38 UTC
Description of problem:
Notification drawer is not displaying upgrade messaging 

Version-Release number of selected component (if applicable):
4.5

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Joe Caiani 2020-05-29 17:28:18 UTC
pr about to merge, and then qa will verify next spring

Comment 4 Yanping Zhang 2020-06-01 09:54:52 UTC
Checked on OCP 4.5 cluster with payload 4.5.0-0.nightly-2020-05-30-025738
There is available update payload for the cluster. Click Notification drawer, in the bottom, there is upgrade message:
Cluster update available
4.5.0-0.nightly-2020-06-01-043833
and "Update cluster" link
Click on the message or the link, it will jump to Cluster Settings detail page.

Comment 5 errata-xmlrpc 2020-07-13 17:42:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.