Bug 1840958 - The content of source can be empty on Wizard general step
Summary: The content of source can be empty on Wizard general step
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Yaacov Zamir
QA Contact: Guohua Ouyang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-28 01:51 UTC by Guohua Ouyang
Modified: 2020-10-27 16:02 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:01:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6270 0 None closed Bug 1840958: Source can be empty in general step 2020-11-02 19:58:20 UTC
Github openshift console pull 6277 0 None closed Bug 1840958: Dont skip validation of url and container sources 2020-11-02 19:58:20 UTC
Github openshift console pull 6278 0 None closed Bug 1840958: Move provision source to component 2020-11-02 19:58:20 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:02:19 UTC

Description Guohua Ouyang 2020-05-28 01:51:52 UTC
Description of problem:
The content of source can be empty on Wizard general step, it's a required field, it should not PASS if it's blank.

Version-Release number of selected component (if applicable):
master

How reproducible:
100%

Steps to Reproduce:
1. On wizard, select URL/Container
2. Don't fill URL/Container Image
3. Fill other fields and Click "Next"

Actual results:
It goes to Network step, and "URL cannot be empty" shows on Storage step.

Expected results:
It should error with "Required fields not completed".

Additional info:

Comment 1 Filip Krepinsky 2020-05-28 12:06:04 UTC
It is required, but it is validated in two places. You can change it in storage tab as well. 

So if you do not specify it you will be stopped in storage tab and required to fill it there.

IMO that is better behaviour as you can deffer the action and fill it in one place together with storage class/size/interface

Comment 2 Tomas Jelinek 2020-05-28 12:11:16 UTC
Based on Comment 1, closing as not a bug.

Comment 3 Guohua Ouyang 2020-05-28 12:27:01 UTC
It does not validate the field in general tab as it could process to next tab.
I can't agree this is a better behavior because it's marked "required" but validate in other place, it's an unusual design.

Comment 4 Tomas Jelinek 2020-05-28 12:29:07 UTC
alright, maybe I had a bit fast trigger :)
Reopening and targeting 4.6 so we can re-discuss the design.

Adding @Matt to the party

Comment 5 Tomas Jelinek 2020-05-29 08:22:30 UTC
It is not clear how to approach it, hence we did not fix it.

Comment 6 Yaacov Zamir 2020-07-08 12:22:34 UTC
re-set severity and priority to medium

AFAIU customers can have all the functionality without any disruption ( high severity say - "customer's operation is disrupted, but there is some capacity to produce." )

Comment 7 Tomas Jelinek 2020-07-10 06:57:30 UTC
We fixed some bugs last sprint, did not have capacity to fix this one. Setting upcoming sprint.

Comment 10 Yaacov Zamir 2020-08-11 07:43:46 UTC
We are removing the red asterisk (indicating required field) from the URL and Container Image fields so users will not think they must fill them in before clicking "Next"

Comment 12 Matt 2020-09-04 03:26:45 UTC
This should be resolved with the new wizard designs where we allow the user to address the source step more specifically in the OS step of the wizard. Would you agree Tomas

Comment 14 errata-xmlrpc 2020-10-27 16:01:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.