Bug 1841005 - `oc new-app -h` need update to create deployment by default
Summary: `oc new-app -h` need update to create deployment by default
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.5
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.6.0
Assignee: Maciej Szulik
QA Contact: zhou ying
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-28 06:27 UTC by zhou ying
Modified: 2020-10-27 16:02 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:01:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift oc pull 440 0 None closed Bug 1841005: fix new-app help to mention deployment and/or dc 2020-09-11 10:28:00 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:02:19 UTC

Description zhou ying 2020-05-28 06:27:16 UTC
Description of problem:
`oc new-app -h` still show create deployment configuration by default, need update to create deployment.

Version-Release number of selected component (if applicable):
[root@dhcp-140-138 cucushift]#  oc version 
Client Version: 4.5.0-202005271737-06cc74b
Kubernetes Version: v1.18.3+0c12308

How reproducible:
always

Steps to Reproduce:
1)`oc new-app -h`

Actual results:
1) show as:
Create a new application by specifying source code, templates, and/or images

....
The images will be deployed via a deployment configuration, and a service will be connected to the first public port of
the app. 

Expected results:
1) Create a new application by specifying source code, templates, and/or images

....
The images will be deployed via a deployment, and a service will be connected to the first public port of
the app. 

Additional info:

Comment 4 zhou ying 2020-06-08 02:25:32 UTC
Confirmed with oc version:

[root@dhcp-140-138 openshift-tests]# oc version -o yaml
clientVersion:
  buildDate: "2020-06-06T02:22:05Z"
  compiler: gc
  gitCommit: e4f466b35d6b3d239ed9eba1764d0ca8aca2dd6b
  gitTreeState: clean
  gitVersion: 4.6.0-202006060217-e4f466b
  goVersion: go1.13.4
  major: ""
  minor: ""
  platform: linux/amd64

[root@dhcp-140-138 openshift-tests]# oc new-app -h
......
 If you specify a source code URL, it will set up a build that takes your source code and converts it into an image that
can run inside of a pod. Local source must be in a git repository that has a remote repository that the server can see.
The images will be deployed via a deployment or deployment configuration, ...

Comment 6 errata-xmlrpc 2020-10-27 16:01:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.