Bug 1841025 - Message under registry filed on instance creation page should not be a super link
Summary: Message under registry filed on instance creation page should not be a super ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.6.0
Assignee: Jon Jackson
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-28 07:46 UTC by XiaochuanWang
Modified: 2020-10-27 16:02 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Some text in schema property descriptions match the format for a a 'fuzzy' hyperlink Consequence: Running this text through the linkify tool causes it to be rendered as a hyperlink Fix: Disable the fuzzy link feature for linkify Result: Only url strings with a proper protocol scheme are rendered as hyperlinks through linkify.
Clone Of:
Environment:
Last Closed: 2020-10-27 16:01:53 UTC
Target Upstream Version:


Attachments (Terms of Use)
bug screenshot (102.41 KB, image/png)
2020-05-28 07:46 UTC, XiaochuanWang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5800 0 None closed Bug 1841025: Disable linkify fuzzy links 2020-10-15 20:02:48 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:02:19 UTC

Description XiaochuanWang 2020-05-28 07:46:38 UTC
Created attachment 1692957 [details]
bug screenshot

Description of problem:
Create a OpenShift Serverless Operator, then go to create Knative Eventing and check the creation page. Under Registry there is a message for registry form but should not be a super link.

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-05-27-202943

How reproducible:
Always

Steps to Reproduce:
1. Create a OpenShift Serverless Operator, then go to Knative Eventing creation page
2. Expand Registry form field and check the helper message. example-registry.io/custom/path/${NAME}:custom-tag

Actual results:
Message contains a super link with "example-registry.io/custom/path/${NAME}:custom-tag"

Expected results:
"example-registry.io/custom/path/${NAME}:custom-tag" should not be a super link.

Additional info:
Also the super link in the right-side panel: Schema > spec > registry

Comment 1 Tomas Jelinek 2020-05-28 12:06:37 UTC
I believe knative belongs to dev console.

Comment 3 cvogt 2020-05-28 18:32:49 UTC
Moving to management console because this looks like an issue with the form generation.

Comment 6 Jon Jackson 2020-07-07 14:19:37 UTC
Working on PR feedback. Should be ready to merge first thing next sprint.

Comment 9 XiaochuanWang 2020-07-27 03:31:12 UTC
`registry.io/custom/path/${NAME}:custom-tag` is not a super link now.
Verified on 4.6.0-0.nightly-2020-07-25-091217

Comment 11 errata-xmlrpc 2020-10-27 16:01:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.