Bug 1841032 - Instance creation form lost text input box for some selector object type of fields
Summary: Instance creation form lost text input box for some selector object type of f...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Jon Jackson
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1847282
TreeView+ depends on / blocked
 
Reported: 2020-05-28 08:02 UTC by XiaochuanWang
Modified: 2020-10-27 16:02 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Introduced and fixed before release.
Clone Of:
: 1847282 (view as bug list)
Environment:
Last Closed: 2020-10-27 16:01:53 UTC
Target Upstream Version:


Attachments (Terms of Use)
bug screenshot (122.86 KB, image/png)
2020-05-28 08:02 UTC, XiaochuanWang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5630 0 None closed Bug 1841032: Fix DynamicForm component logic for hiding schemas that do not produce form fields 2021-02-18 04:05:51 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:02:19 UTC

Description XiaochuanWang 2020-05-28 08:02:37 UTC
Created attachment 1692964 [details]
bug screenshot

Description of problem:
When user create operator instance such as "Knative Serving" with "OpenShift Serverless Operator", on the Form View check "Cluster LocalGateway" and "Knative Ingress Gateway", there is no input box for the value.

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-05-27-202943

How reproducible:
Always

Steps to Reproduce:
1. User create operator "OpenShift Serverless Operator"
2. Go to create instance "Knative Serving" on Form View
3. Expand "Cluster LocalGateway" and "Knative Ingress Gateway" and check

Actual results:
There is no input box for the value.

Expected results:
There should be an input box for each params

Additional info:
Both of them are selector object type of params.

Comment 1 Tomas Jelinek 2020-05-28 12:08:45 UTC
I believe knative is dev console

Comment 5 Yanping Zhang 2020-06-04 11:32:34 UTC
Checked on ocp 4.6 cluster with payload 4.6.0-0.ci-2020-06-04-011434.
1. User create operator "OpenShift Serverless Operator"
2. Go to create instance "Knative Serving" on Form View, check on the form page, there is no param without input field now.

Comment 7 errata-xmlrpc 2020-10-27 16:01:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.