Bug 1841109 - [ovirt-csi] missing /run/udev will cause staging failure
Summary: [ovirt-csi] missing /run/udev will cause staging failure
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.0
Assignee: aos-storage-staff@redhat.com
QA Contact: Guilherme Santos
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-28 11:38 UTC by Roy Golan
Modified: 2020-10-27 16:02 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:01:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift ovirt-csi-driver pull 39 0 None closed Bug 1841109: Pass /run/udev to the node controller 2020-11-24 10:43:02 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:02:36 UTC

Description Roy Golan 2020-05-28 11:38:01 UTC
Description of problem:

In volume staging the driver scans the volume and if it doesn't have a file system on it, it will create one. 
When /run/udev is missing lsblk will not have any information on the filesystem,  and with not failure reported. in other words this will overwrite the volume filesystem.

Version-Release number of selected component (if applicable):

How reproducible:
100%

Comment 5 Guilherme Santos 2020-06-29 19:03:10 UTC
Tested on:
openshift-4.4.0-0.nightly-2020-06-14-013357
(the ovirt-csi operator functionality doesn't depend on the ocp version itself, 
the bz is marked as 4.5, because the operator is being added in this version)
ovirt-engine-4.4.1.2-0.10.el8ev.noarch

Steps:
- Manually installed the operator following: https://github.com/openshift/ovirt-csi-driver-operator
- Created and deployed a test pod that uses csi pvc disk
# oc create -f testpodwithcsi.yaml 
- Once installed and in operation, created a dummy file in the mounted pv directory (my case /opt):
# oc rsh testpodwithcsi
# cd /opt && touch dummy.file
- Deleted the pod, without touching the pvc, and deployed a new one:
# oc delete pod testpodwithcsi && oc create -f testpodwithcsi.yaml
- Checked if the created file still there (thus, no FS rewritten)

Results:
Failed, the FS was rewritten, because the yaml file that got the fix is not being used by the operator

Comment 6 Guilherme Santos 2020-06-29 19:03:53 UTC
Tested on:
openshift-4.4.0-0.nightly-2020-06-14-013357
(the ovirt-csi operator functionality doesn't depend on the ocp version itself, 
the bz is marked as 4.5, because the operator is being added in this version)
ovirt-engine-4.4.1.2-0.10.el8ev.noarch

Steps:
- Manually installed the operator following: https://github.com/openshift/ovirt-csi-driver-operator
- Created and deployed a test pod that uses csi pvc disk
# oc create -f testpodwithcsi.yaml 
- Once installed and in operation, created a dummy file in the mounted pv directory (my case /opt):
# oc rsh testpodwithcsi
# cd /opt && touch dummy.file
- Deleted the pod, without touching the pvc, and deployed a new one:
# oc delete pod testpodwithcsi && oc create -f testpodwithcsi.yaml
- Checked if the created file still there (thus, no FS rewritten)

Results:
Failed, the FS was rewritten, because the yaml file that got the fix is not being used by the operator

Comment 7 XiuJuan Wang 2020-06-30 03:43:41 UTC
Hey Guilherme,

Could you check bug on 4.5 version? The bug is added in 4.5 released.

Comment 8 Roy Golan 2020-06-30 05:20:02 UTC
Retargeting because our operator will be available only in 4.6

Comment 10 Guilherme Santos 2020-07-07 16:17:16 UTC
Will test it on 4.6

Comment 13 Guilherme Santos 2020-07-28 13:14:59 UTC
Verified on:
openshift-4.6.0-0.nightly-2020-07-22-074636
ovirt-engine-4.3.11.2-0.1.el7.noarch

Steps:
- same as comment #5

Results:
created file stills there, FS not rewritten

Comment 16 errata-xmlrpc 2020-10-27 16:01:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.