Bug 1841146 - Virtual Machine Template with a disk without immediate DataVolume cannot be deleted
Summary: Virtual Machine Template with a disk without immediate DataVolume cannot be d...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.5.0
Assignee: Filip Krepinsky
QA Contact: Guohua Ouyang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-28 13:30 UTC by Radim Hrazdil
Modified: 2020-07-13 17:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:42:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5626 0 None closed Bug 1841146: allow deleting Templates with not yet created DataVolumes 2020-06-24 03:29:17 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:42:44 UTC

Description Radim Hrazdil 2020-05-28 13:30:05 UTC
Description of problem:
When a user creates a Virtual Machine Template with a disk for which there isn't immediately created datavolume (Blank disk), the VMT then cannot be deleted, because the Delete Modal is trying to search the DataVolume, which doesn't exist.

Note that such disk cannot be deleted using the kebab action either.

Possible workaround is removing the disk using the yaml editor, 

Version-Release number of selected component (if applicable):
4.5

How reproducible:
100%

Comment 4 Radim Hrazdil 2020-06-01 09:17:31 UTC
Verified, release-4.5, commit: 145273f2f22800dda59f208d2d51a75191f376a4

Comment 5 errata-xmlrpc 2020-07-13 17:42:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.