Bug 1841154 - Cannot add Attach Disk to Virtual Machine Template because of disabled PVC select dropdown
Summary: Cannot add Attach Disk to Virtual Machine Template because of disabled PVC se...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Filip Krepinsky
QA Contact: Guohua Ouyang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-28 13:42 UTC by Radim Hrazdil
Modified: 2020-07-13 17:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause and Consequence: It was not possible to Attach Disk to Virtual Machine Template Fix and Result: It is possible to Attach Disk to Virtual Machine Template
Clone Of:
Environment:
Last Closed: 2020-07-13 17:42:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5628 0 None open Bug 1841154: fix attaching disk in VM templates 2020-06-24 03:29:17 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:42:55 UTC

Description Radim Hrazdil 2020-05-28 13:42:52 UTC
Description of problem:
When user attempts to Attach disk to a VM Template, the PVC selector is disabled, and a PVC then cannot be selected.
The same flow works as expected with a Virtual Machine.


Datavolume:
apiVersion: cdi.kubevirt.io/v1alpha1
kind: DataVolume
metadata:
  name: example-import-dv
spec:
  pvc:
    accessModes:
      - ReadWriteOnce
    resources:
      requests:
        storage: 500Mi
  source:
    http:
      url: >-
        http://cnv-qe-server.rhevdev.lab.eng.rdu2.redhat.com/files/files-https/cirros/cirros-qcow2.img


Version-Release number of selected component (if applicable):
4.5


Steps to Reproduce:
1. Create example Template
2. Create a DV, example given above
3. Try to add attach disk to the VM Template

Actual results:
PVC Selector is disabled, so the dialog cannot be submitted

Comment 1 Tomas Jelinek 2020-05-29 08:24:52 UTC
working on it now

Comment 4 Radim Hrazdil 2020-06-01 07:41:44 UTC
Verified on release-4.5
Attaching a disk works as expected, deleting a VMT with attached disk doesn't delete the attached disk

Comment 5 errata-xmlrpc 2020-07-13 17:42:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.