Bug 1841302 - Cluster Trigger Bindings shouldn't list resources
Summary: Cluster Trigger Bindings shouldn't list resources
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Andrew Ballantyne
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-28 19:41 UTC by Andrew Ballantyne
Modified: 2020-07-13 17:42 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:42:41 UTC
Target Upstream Version:


Attachments (Terms of Use)
Cluster Trigger Bindings shouldn't list resources (87.51 KB, image/png)
2020-06-03 11:43 UTC, spathak@redhat.com
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5623 0 None closed Bug 1841302: Remove custom ClusterTriggerBinding details page 2020-06-24 03:29:21 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:42:55 UTC

Description Andrew Ballantyne 2020-05-28 19:41:48 UTC
Description of problem:
When associating a ClusterTriggerBinding to a namespaced Pipeline exposes a reference to the EventListener namespace object that used it.

This is an issue as Cluster resources do not have a namespace and thus cannot traverse into the resource nicely.


Version-Release number of selected component (if applicable):
OpenShift Pipeline Operator 1.0.x

How reproducible:


Steps to Reproduce:

1. Create a new project
2. oc apply -f https://raw.githubusercontent.com/andrewballantyne/pipeline-scratch-pad/master/examples/triggers/ui/resources.yaml
3. Add a Cluster Trigger Binding and a Trigger Binding trigger to the pipeline added to the project you're in
3a. Go to the Pipelines page, "Add Trigger" on the pipeline from the actions
3b. In the first drop down select github, other values do not matter - just fill them in with garbage
3c. Repeat and do it again for github-push

Actual results:
See resource links on the `github-push` resource that don't work

Expected results:
Not to see any resources on the `github-push` details page

Additional info:

Comment 4 spathak@redhat.com 2020-06-03 11:43:07 UTC
Created attachment 1694807 [details]
Cluster Trigger Bindings shouldn't list resources

Comment 5 spathak@redhat.com 2020-06-03 11:49:37 UTC
Verified on build version:4.5.0-0.ci-2020-06-02-094408
Browser version: Firefox 73

Comment 6 errata-xmlrpc 2020-07-13 17:42:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.