Bug 1841411 - dpdk-2:19.11.1-2.fc32.x86_64 conflicts with openvswitch-2.12.0-2.fc32.x86_6
Summary: dpdk-2:19.11.1-2.fc32.x86_64 conflicts with openvswitch-2.12.0-2.fc32.x86_6
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: dpdk
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Timothy Redaelli
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-29 05:32 UTC by Davide Repetto
Modified: 2020-06-03 08:00 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-03 07:58:34 UTC
Type: Bug


Attachments (Terms of Use)

Description Davide Repetto 2020-05-29 05:32:47 UTC
Description of problem:
dpdk-2:19.11.1-2.fc32.x86_64 conflicts with openvswitch-2.12.0-2.fc32.x86_6

Probably beening pushed too soon?

Comment 1 Neil Horman 2020-05-29 10:38:12 UTC
whats the conflict?  dpdk-19.11 has been out for a month (the last update on May 19 just fixed a few CVEs, and didn't change any library dependencies)

Comment 2 Davide Repetto 2020-05-29 12:07:59 UTC
I'm sorry, I meant rpm dependency conflict.


# dnf upgrade -y

Ultima verifica della scadenza dei metadati: 0:09:53 fa il ven 29 mag 2020, 11:51:02.
Dipendenze risolte.

 Problema: package openvswitch-2.12.0-2.fc32.x86_64 requires librte_acl.so.2()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_bbdev.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_bitratestats.so.2()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_bpf.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_bus_dpaa.so.2()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_bus_fslmc.so.2()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_bus_ifpga.so.2()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_bus_pci.so.2()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_bus_vdev.so.2()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_bus_vmbus.so.2()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_cfgfile.so.2()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_cmdline.so.2()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_common_cpt.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_common_dpaax.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_common_octeontx.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_compressdev.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_cryptodev.so.5()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_distributor.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_eal.so.9()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_eal.so.9(DPDK_17.08)(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_eal.so.9(DPDK_18.11)(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_eal.so.9(DPDK_2.0)(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_efd.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_ethdev.so.11()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_ethdev.so.11(DPDK_16.07)(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_ethdev.so.11(DPDK_17.05)(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_ethdev.so.11(DPDK_18.05)(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_ethdev.so.11(DPDK_18.08)(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_ethdev.so.11(DPDK_18.11)(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_ethdev.so.11(DPDK_2.2)(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_eventdev.so.6()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_flow_classify.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_gro.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_gso.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_hash.so.2()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_ip_frag.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_jobstats.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_kvargs.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_latencystats.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_lpm.so.2()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_mbuf.so.4()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_mbuf.so.4(DPDK_2.1)(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_member.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_mempool.so.5()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_mempool.so.5(DPDK_16.07)(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_mempool.so.5(DPDK_2.0)(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_mempool_bucket.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_mempool_dpaa.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_mempool_dpaa2.so.2()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_mempool_octeontx.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_mempool_ring.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_mempool_stack.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_meter.so.2()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_meter.so.2(DPDK_18.08)(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_meter.so.2(DPDK_2.0)(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_metrics.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_net.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pci.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pdump.so.2()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pdump.so.2(DPDK_16.07)(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pipeline.so.3()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_af_packet.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_ark.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_atlantic.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_avf.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_avp.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_axgbe.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_bbdev_null.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_bnx2x.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_bnxt.so.2()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_bond.so.2()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_caam_jr.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_crypto_scheduler.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_cxgbe.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_dpaa.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_dpaa2.so.2()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_dpaa2_cmdif.so.2()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_dpaa2_event.so.2()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_dpaa2_qdma.so.2()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_dpaa2_sec.so.2()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_dpaa_event.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_dpaa_sec.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_dsw_event.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_e1000.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_ena.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_enetc.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_enic.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_failsafe.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_fm10k.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_i40e.so.2()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_ifc.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_ifpga_rawdev.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_ixgbe.so.2()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_lio.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_netvsc.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_nfp.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_null.so.2()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_null_crypto.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_octeontx.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_octeontx_crypto.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_octeontx_ssovf.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_octeontx_zip.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_opdl_event.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_pcap.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_qat.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_qede.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_ring.so.2()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_ring.so.2(DPDK_2.0)(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_sfc_efx.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_skeleton_event.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_skeleton_rawdev.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_softnic.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_sw_event.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_tap.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_thunderx_nicvf.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_vdev_netvsc.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_vhost.so.2()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_virtio.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_virtio_crypto.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_pmd_vmxnet3_uio.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_port.so.3()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_rawdev.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_reorder.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_ring.so.2()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_ring.so.2(DPDK_2.0)(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_sched.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_security.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_table.so.3()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_timer.so.1()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_vhost.so.4()(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_vhost.so.4(DPDK_16.07)(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_vhost.so.4(DPDK_17.05)(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_vhost.so.4(DPDK_17.08)(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_vhost.so.4(DPDK_2.0)(64bit), but none of the providers can be installed
  - package openvswitch-2.12.0-2.fc32.x86_64 requires librte_vhost.so.4(DPDK_2.1)(64bit), but none of the providers can be installed
  - cannot install both dpdk-2:19.11.1-2.fc32.x86_64 and dpdk-2:18.11.6-1.fc32.x86_64
  - cannot install both dpdk-2:18.11.6-1.fc32.x86_64 and dpdk-2:19.11.1-2.fc32.x86_64
  - cannot install the best update candidate for package openvswitch-2.12.0-2.fc32.x86_64
  - cannot install the best update candidate for package dpdk-2:18.11.6-1.fc32.x86_64
=====================================================================================================================================
 Package                    Architecture                 Version                                 Repository                     Size
=====================================================================================================================================
Esclusione dei pacchetti con conflitti:
(aggiungere '--best --allowerasing' alla linea di comando per forzarne l'aggiornamento):
 dpdk                       x86_64                       2:19.11.1-2.fc32                        updates                       4.0 M

Riepilogo della transazione
=====================================================================================================================================
Ignorati  1 pacchetto

Nessuna operazione da compiere.
Fatto!

Comment 3 Timothy Redaelli 2020-05-29 14:59:20 UTC
The problem was that I created https://bodhi.fedoraproject.org/updates/FEDORA-2020-add0c5f7c9 to update dpdk and openvswitch at the same time,
but later dpdk was pushed with another bodhi without openvswitch and and so the dependency was broken.

Can you try to install opensvwitch from testing (and maybe give me a karma so I can push it to stable)?

# dnf --enablerepo updates-testing update openvswitch

Comment 4 Neil Horman 2020-05-29 18:14:13 UTC
Ok, based on timothys comment, it sounds like this will be fixed by a push of openvswitch, so I'm reassigning this to you.  Please close when the fix is confirmed.

Comment 5 Andre Robatino 2020-05-29 20:41:20 UTC
(In reply to Timothy Redaelli from comment #3)
> The problem was that I created
> https://bodhi.fedoraproject.org/updates/FEDORA-2020-add0c5f7c9 to update
> dpdk and openvswitch at the same time,
> but later dpdk was pushed with another bodhi without openvswitch and and so
> the dependency was broken.
> 
> Can you try to install opensvwitch from testing (and maybe give me a karma
> so I can push it to stable)?
> 
> # dnf --enablerepo updates-testing update openvswitch

I gave a karma of +1, karma still shows as 0 despite karma supposedly having been reset to 0 before.

Comment 6 Andre Robatino 2020-05-29 20:42:54 UTC
Sorry, my mistake. Added karma for real.

Comment 7 Andre Robatino 2020-05-29 20:58:34 UTC
Also see my comment on https://bodhi.fedoraproject.org/updates/FEDORA-2020-add0c5f7c9 regarding the latest version of dpdk-examples not being installable.

Comment 8 Andre Robatino 2020-05-30 02:09:26 UTC
This bug was just fixed since https://bodhi.fedoraproject.org/updates/FEDORA-2020-add0c5f7c9 was pushed to stable. The problem with dpdk-examples not being installable still exists, I filed https://bugzilla.redhat.com/show_bug.cgi?id=1841960 for that.

Comment 9 Davide Repetto 2020-06-03 07:58:34 UTC
Now upgraded to dpdk-19.11.1-2.fc32.x86_64 & openvswitch-2.13.0-1.fc32.x86_64 and it works for me.


Note You need to log in before you can comment on or make changes to this bug.