Bug 1841860 - Desktop link files with Terminal=true don't work after KDE Frameworks 5.70.0 update
Summary: Desktop link files with Terminal=true don't work after KDE Frameworks 5.70.0 ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kf5-kio
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-29 16:33 UTC by samoht0
Modified: 2020-06-04 02:54 UTC (History)
5 users (show)

Fixed In Version: kf5-kio-5.70.1-2.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-04 02:54:51 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
KDE Software Compilation 421374 VHI RESOLVED Service file specifiying 'Run in terminal' gives "Error code 100, Could not find the program ‘konsole’" after Plasma 5.1... 2020-05-31 07:20:34 UTC
KDE Software Compilation 422270 NOR RESOLVED Desktop link files with Terminal=true don't work after KDE Frameworks 5.70.0 update 2020-05-31 07:23:08 UTC

Description samoht0 2020-05-29 16:33:30 UTC
Description of problem:

After updating KDE Frameworks to 5.70.0 .desktop link files for terminal programmes (Terminal=true) result in a message saying "konsole" can't be found. Opening a "konsole" from GUI menu works fine, so binary is available.

Blaming component "kf5-kio" is just a guess.

Linking to GUI apps woks anyway.

How reproducible:

Create a .desktop link file ("[Desktop Entry]") with run in terminal option (binary file or script doesn't matter).
Run the Link by clicking on it. Error message appears.

Comment 1 Rex Dieter 2020-05-30 03:36:36 UTC
Can you confirm the behavior remains after restarting your session? (ie, logout/login, or reboot)

Comment 2 samoht0 2020-05-30 07:11:25 UTC
(In reply to Rex Dieter from comment #1)
> Can you confirm the behavior remains after restarting your session? (ie,
> logout/login, or reboot)

Yes, even after reboot.

Plus, I've got the same result on a second system (both are clean F32 net-installs KDE with KDE-Apps, Admin-Tools and Libre-Office as extra option). Desktop-links worked fine, updated using DNF, logout/login ... and broken.

Cleaning qmlcaches in ~/.cache didn't help.

Comment 3 samoht0 2020-05-30 07:58:58 UTC
This is in the journal:

'Internal program error. QStandardPaths::findExecutable couldn't find "konsole" but our own logic found it at "/usr/bin/konsole".'

Oh my, it's found by internal logic and don't start anyway.

Comment 4 samoht0 2020-05-30 09:43:43 UTC
This commit fixing another bug might be related:
https://bugs.kde.org/show_bug.cgi?id=415567

At least, the detection logic was changed and exactly those error text was added.

+ qWarning() << "Internal program error. QStandardPaths::findExecutable couldn't find" << executable << "but our own logic found it at" << candidate << ". Please report a bug at https://bugs.kde.org";

Comment 5 Rex Dieter 2020-05-30 18:22:15 UTC
Ok, need to get this reported upstream @ bugs.kde.org asap.  I'll be able to it later tonight or tomorrow, but if you (or anyone) could be me to it, would be much appreciated.

Comment 6 samoht0 2020-05-30 21:32:55 UTC
(In reply to Rex Dieter from comment #5)
> Ok, need to get this reported upstream @ bugs.kde.org asap.  I'll be able to
> it later tonight or tomorrow, but if you (or anyone) could be me to it,
> would be much appreciated.

I've filed a bug. Please comment upstream, if there's something to add.

Comment 7 Rex Dieter 2020-05-31 01:05:35 UTC
Thanks!

Comment 8 samoht0 2020-05-31 07:26:17 UTC
It turns out, the bug was already tracked and there's a commit, that could be included in a bug-fix build:
https://bugs.kde.org/show_bug.cgi?id=421374#c14

Comment 9 Rex Dieter 2020-06-01 04:38:37 UTC
Pulled in upstream fix,
https://src.fedoraproject.org/rpms/kf5-kio/c/4e7fe5feb9243092d539b644c10101a0c1e8e1ba?branch=master

builds underway.

Comment 10 samoht0 2020-06-01 06:34:32 UTC
(In reply to Rex Dieter from comment #9)
> builds underway.

Gr8! Will test and comment in bodhi, when pushed in testing.

Comment 11 Fedora Update System 2020-06-01 14:42:10 UTC
FEDORA-2020-81515f4932 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-81515f4932

Comment 12 Fedora Update System 2020-06-02 05:03:45 UTC
FEDORA-2020-81515f4932 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-81515f4932`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-81515f4932

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 13 Fedora Update System 2020-06-04 02:54:51 UTC
FEDORA-2020-81515f4932 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.