Bug 1841909 - import from git flow does not validate custom git repository
Summary: import from git flow does not validate custom git repository
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.6.0
Assignee: Aritra Roy
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks: 1893022
TreeView+ depends on / blocked
 
Reported: 2020-05-29 19:24 UTC by cvogt
Modified: 2020-10-29 22:55 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1893022 (view as bug list)
Environment:
Last Closed: 2020-10-27 16:01:56 UTC
Target Upstream Version:


Attachments (Terms of Use)
validate git url on selecting git type (531.93 KB, image/gif)
2020-06-10 02:05 UTC, Aritra Roy
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5706 0 None closed Bug 1841909: Fix git validation on selecting git type 2020-12-01 11:39:47 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:02:28 UTC

Description cvogt 2020-05-29 19:24:58 UTC
Description of problem:
Custom Git repositories are not validated during git import flows unless the repo URL is from `github`, `gitlab` or `bitbucket`.


Version-Release number of selected component (if applicable):
4.5.0-0.ci-2020-05-26-143043

How reproducible:


Steps to Reproduce:
1. Go to dev perspective -> Import from Git
2. Enter git URL `https://version.helsinki.fi/tommi.tuura/public-project`
3. Select Git Type `GitLab`

Actual results:
Error `Git repository is not reachable`.


Expected results:
Once the Git Type is entered correctly, the validation should re-run.


Additional info:

Comment 2 cvogt 2020-06-08 16:37:40 UTC
After the git type is selected, validation should be re-run and if successful, the help text should reflect the successful validation.
Furthermore, for the git import flow, the builder image detection should re-run after successfully connecting to the git repository using the git APIs.

Comment 3 Aritra Roy 2020-06-10 02:05:08 UTC
Created attachment 1696428 [details]
validate git url on selecting git type

Comment 7 Sergio G. 2020-10-06 08:22:17 UTC
Is there any backport planned for 4.5?

Comment 10 Sergio G. 2020-10-26 07:27:01 UTC
Is there any backport planned for 4.5?

Comment 11 errata-xmlrpc 2020-10-27 16:01:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196

Comment 12 Sergio G. 2020-10-28 08:23:23 UTC
No backport to 4.5?

Comment 13 Aritra Roy 2020-10-28 15:42:59 UTC
Hi @sgarciam@redhat.com,
A backport to 4.5 has been initialized and will be put up soon.
Thank you for your patience.


Note You need to log in before you can comment on or make changes to this bug.