Bug 184216 - init script kills all running sshd's if listening server is stopped
Summary: init script kills all running sshd's if listening server is stopped
Status: CLOSED DUPLICATE of bug 170468
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openssh (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
: ---
Assignee: Tomas Mraz
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-07 13:40 UTC by Bastien Nocera
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-07 14:44:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bastien Nocera 2006-03-07 13:40:56 UTC
+++ This bug was initially created as a clone of Bug #167886 +++

+++ This bug was initially created as a clone of Bug #67624 +++

From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020412
Debian/1.2.0-6

Description of problem:
The init script /etc/init.d/sshd uses the function killproc from
/etc/rc.d/init.d/functions. This falls back to using the pidof command to get
PIDs for the daemon, if /var/run/[service].pid does not exist. This means that
if the ssh server is already stopped, instead of failing with "ssh server is not
running" or something similiar, it kills all other running sshd's, which,
obviously, kills everyone's connections to the server. This has a high inpact
if the server is remote and there is no easy console access.

Comment 1 Tomas Mraz 2006-03-07 14:44:15 UTC
Already fixed in RHEL4U3 package.


*** This bug has been marked as a duplicate of 170468 ***


Note You need to log in before you can comment on or make changes to this bug.