Bug 184236 - Modify "adduser" to use /etc/libuser.conf
Modify "adduser" to use /etc/libuser.conf
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: shadow-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-07 11:25 EST by Robin
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-08 07:17:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin 2006-03-07 11:25:46 EST
Request for enhancement.

After submitting bug 174204 (system-config-users doesn't use login.defs
settings) and finding that this is a normal problem and works as is, it would be
a good idea to either modify the adduser program to use /etc/libuser.conf
instead of /etc/login.defs, so that automated scripts or CLI addition of users
won't miss any congiguration changes done in /etc/libuser.conf.  Maybe adduser
can be modified to use the same formatted file as libuser.conf and then a
simlink can be used.

There should only be one congiguration file for simplicity.
Comment 1 Miloslav Trmač 2006-03-07 17:08:47 EST
No, that would cause infinite recursion :)

libuser already (since 0.54.1) imports some settings from /etc/login.defs and
/etc/default/useradd.

Please sese (man libuser.conf) for details.

Note You need to log in before you can comment on or make changes to this bug.