Bug 1842460 - [Descheduler] - The minKubeVersion should be 1.18.3
Summary: [Descheduler] - The minKubeVersion should be 1.18.3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-scheduler
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.6.0
Assignee: Jan Chaloupka
QA Contact: RamaKasturi
URL:
Whiteboard:
: 1842874 (view as bug list)
Depends On:
Blocks: 1842853 1842874
TreeView+ depends on / blocked
 
Reported: 2020-06-01 10:11 UTC by RamaKasturi
Modified: 2020-10-27 16:03 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1842853 (view as bug list)
Environment:
Last Closed: 2020-10-27 16:02:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:03:28 UTC

Description RamaKasturi 2020-06-01 10:11:10 UTC
Description of problem:
[ramakasturinarra@dhcp35-60 ~]$ oc get csv clusterkubedescheduleroperator.4.5.0-202005301517 -n openshift-kube-descheduler-operator -o json | jq '.spec.minKubeVersion'
"1.17.0"

minKubeVersion should be set to 1.18.3 where as currently it is set as 1.17.0

Version-Release number of selected component (if applicable):
[ramakasturinarra@dhcp35-60 ~]$ oc version
Client Version: 4.5.0-202005291417-9933eb9
Server Version: 4.5.0-0.nightly-2020-05-31-230932
Kubernetes Version: v1.18.3+a637491


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Jan Chaloupka 2020-06-02 08:24:10 UTC
Rama, I am ignoring the patch version since the difference between individual patches is negligible for the operator. So, setting minKubeVersion to 1.18.0.

Comment 3 Maciej Szulik 2020-06-02 09:47:02 UTC
*** Bug 1842874 has been marked as a duplicate of this bug. ***

Comment 4 Jan Chaloupka 2020-06-03 08:37:46 UTC
Upstream PR: https://github.com/openshift/cluster-kube-descheduler-operator/pull/109

Comment 5 RamaKasturi 2020-06-03 09:27:31 UTC
Verified bug in the PR present in comment 4 and i see that the minKubeVersion is set as 1.18.0, so moving the bug to verified state.

 minKubeVersion: 1.18.0

Comment 8 errata-xmlrpc 2020-10-27 16:02:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.