Bug 1842560 - Improve APIServerError condition name many degraded clusters report
Summary: Improve APIServerError condition name many degraded clusters report
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Samples
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.z
Assignee: Gabe Montero
QA Contact: XiuJuan Wang
URL:
Whiteboard:
: 1842561 (view as bug list)
Depends On: 1838716
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-01 14:24 UTC by OpenShift BugZilla Robot
Modified: 2020-06-17 22:27 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: sample operator file system errors were incorrectly reported as api server errors in the clusteroperator reason field, and details on actual api server errors while manipulating api server objects did not provide detail on the exact type of failure Consequence: analysis of degraded samples operator reported via OTA/insights was unnecessarily hindered Fix: file system errors are reported as file system errors in the degraded reason field, and api server errors reported in the degraded reason field include the specific error type Result: degraded samples operator conditions around api server errors and file system errors are more easily triaged
Clone Of:
Environment:
Last Closed: 2020-06-17 22:27:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-samples-operator pull 282 None closed [release-4.4] Bug 1842560: improve reason text on degraded condition 2020-06-08 02:04:38 UTC
Red Hat Product Errata RHBA-2020:2445 None None None 2020-06-17 22:27:13 UTC

Comment 1 Gabe Montero 2020-06-01 22:16:22 UTC
*** Bug 1842561 has been marked as a duplicate of this bug. ***

Comment 4 XiuJuan Wang 2020-06-05 08:18:04 UTC
The latest payload 4.4.0-0.nightly-2020-06-03-225439 don't included the fix, waiting for new payload.

Comment 5 XiuJuan Wang 2020-06-08 08:51:04 UTC
I got the APIServerServiceUnavailableError in openshift-samples clusteroperator after delete three nopenshift-apiserver pods against 4.4.0-0.nightly-2020-06-07-075345
A.
1) mark samples operator removed
2) scale down / kill the 3 openshift api server pods
3) then catch the openshift-samples clusteroperator being in degraded status and see what the reason is

  conditions:
  - lastTransitionTime: "2020-06-08T08:29:54Z"
    status: "False"
    type: Available
  - lastTransitionTime: "2020-06-08T08:29:54Z"
    message: 'Samples installation in error at 4.4.0-0.nightly-2020-06-07-075345:
      APIServerServiceUnavailableError'
    status: "True"
    type: Progressing
  - lastTransitionTime: "2020-06-08T08:29:54Z"
    message: The error the server is currently unable to handle the request (get imagestreams.image.openshift.io)
      during openshift namespace cleanup has left the samples in an unknown state;
    reason: APIServerServiceUnavailableError
    status: "True"
    type: Degraded
  extension: null

B.
1) mark samples operator removed
2)Wait samples are removed, mark samples to Managed
3) kill the 3 openshift api server pods
4) then catch the openshift-samples clusteroperator being in degraded status and see what the reason is

status:
  conditions:
  - lastTransitionTime: "2020-06-08T08:28:28Z"
    status: "False"
    type: Available
  - lastTransitionTime: "2020-06-08T08:28:28Z"
    message: 'Samples installation in error at 4.4.0-0.nightly-2020-06-07-075345:
      APIServerServiceUnavailableError'
    status: "True"
    type: Progressing
  - lastTransitionTime: "2020-06-08T08:28:31Z"
    message: 'error creating samples: the server is currently unable to handle the
      request (post imagestreams.image.openshift.io);imagestream create error: the
      server is currently unable to handle the request (post imagestreams.image.openshift.io);'
    reason: APIServerServiceUnavailableError
    status: "True"
    type: Degraded

Comment 7 errata-xmlrpc 2020-06-17 22:27:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2445


Note You need to log in before you can comment on or make changes to this bug.