Bug 1842644 - please add stress-ng to epel8
Summary: please add stress-ng to epel8
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: stress-ng
Version: epel8
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christopher Brown
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1739408 (view as bug list)
Depends On: 1854339
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-01 18:40 UTC by Davide Cavalca
Modified: 2020-09-02 13:52 UTC (History)
6 users (show)

Fixed In Version: stress-ng-0.11.14-6.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-02 13:52:43 UTC
Type: Bug


Attachments (Terms of Use)

Description Davide Cavalca 2020-06-01 18:40:30 UTC
stress-ng is available in EPEL 6 and 7, but is currently missing from EPEL 8. Would it be possible to have it built for it? Thanks!

Comment 1 Christopher Brown 2020-07-03 22:18:50 UTC
In the interim I've created a copr repo:

https://copr.fedorainfracloud.org/coprs/snecker/stress-ng/

Spec file here:

https://github.com/snecklifter/stress-ng

Fedora PR here:

https://src.fedoraproject.org/rpms/stress-ng/pull-request/1

Comment 2 Fabio Alessandro Locati 2020-07-06 20:04:11 UTC
I've requested the branch already ;-)
https://pagure.io/releng/fedora-scm-requests/issue/26868

we just need to wait that is created and then push the package

Comment 3 Christopher Brown 2020-07-06 20:06:36 UTC
*** Bug 1739408 has been marked as a duplicate of this bug. ***

Comment 4 Christopher Brown 2020-07-24 20:50:41 UTC
@Fale @jiwikins

We can just ship stress-ng in EPEL without Judy whilst that situation is resolved? Judy stressor was added fairly recently and is not a hard requirement.

https://github.com/ColinIanKing/stress-ng/commit/6b667fd788f1f10cdcdbb4fe3b98299b0e7de510

WDYT?

Comment 5 James Wilkins 2020-07-29 06:58:34 UTC
I'm happy shipping as is without Judy

Comment 6 Fedora Update System 2020-08-18 21:37:53 UTC
FEDORA-EPEL-2020-d70e8087f3 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-d70e8087f3

Comment 7 Fedora Update System 2020-08-19 01:38:10 UTC
FEDORA-EPEL-2020-d70e8087f3 has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-d70e8087f3

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2020-09-02 13:52:43 UTC
FEDORA-EPEL-2020-d70e8087f3 has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.