Bug 1842653 - [4.4] All NetworkPolicy tests currently being skipped on openshift-sdn
Summary: [4.4] All NetworkPolicy tests currently being skipped on openshift-sdn
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.z
Assignee: Dan Winship
QA Contact: zhaozhanqi
URL:
Whiteboard:
Depends On: 1845078
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-01 19:07 UTC by Dan Winship
Modified: 2020-10-13 08:18 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1842650
Environment:
Last Closed: 2020-10-13 08:17:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin pull 25197 0 None closed Bug 1842653: [4.4] All NetworkPolicy tests currently being skipped on openshift-sdn 2020-09-27 07:21:23 UTC
Red Hat Product Errata RHBA-2020:4063 0 None None None 2020-10-13 08:18:17 UTC

Description Dan Winship 2020-06-01 19:07:17 UTC
+++ This bug was initially created as a clone of Bug #1842650 +++

The current version of the test-skipping code doesn't distinguish "[Skipped:Network/OpenShiftSDN]" from "[Skipped:Network/OpenShiftSDN/Multitenant]" the way that the old code did, and as a result, we are skipping the NetworkPolicy tests in all openshift-sdn-based runs, rather than only skipping them in e2e-aws-multitenant as was intended.

Comment 2 Steve Kuznetsov 2020-06-04 15:16:19 UTC
Moving to Networking component, this is not under purview of DPTP.

Comment 3 Dan Winship 2020-06-08 12:30:26 UTC
closing, the bot will file its own copy

Comment 4 Dan Winship 2020-07-08 12:23:19 UTC
PR is waiting for flaky CI to pass... probably not going to merge this sprint

Comment 5 Dan Winship 2020-09-10 15:00:37 UTC
(In reply to Dan Winship from comment #4)
> PR is waiting for flaky CI to pass... probably not going to merge this sprint

Comment 7 zhaozhanqi 2020-09-28 08:37:34 UTC
Check this job https://prow.ci.openshift.org/view/gs/origin-ci-test/logs/release-openshift-ocp-installer-e2e-aws-4.4/1309948375960915968
network policy tests has been back.  Move this bug to 'verified'

Comment 10 errata-xmlrpc 2020-10-13 08:17:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.4.27 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4063


Note You need to log in before you can comment on or make changes to this bug.