Bug 1842721 - No module named 'ruamel'
Summary: No module named 'ruamel'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.6.0
Assignee: Jeff Cantrill
QA Contact: Anping Li
URL:
Whiteboard: needsqa
Depends On:
Blocks: 1842439
TreeView+ depends on / blocked
 
Reported: 2020-06-01 23:41 UTC by Jeff Cantrill
Modified: 2020-10-27 16:03 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1842439
Environment:
Last Closed: 2020-10-27 16:03:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin-aggregated-logging pull 1910 0 None closed Bug 1842721: vendor ruamel.yaml 2020-10-23 23:03:33 UTC
Red Hat Knowledge Base (Solution) 5306571 0 None None None 2020-08-13 07:23:57 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:03:29 UTC

Description Jeff Cantrill 2020-06-01 23:41:21 UTC
+++ This bug was initially created as a clone of Bug #1842439 +++

Description of problem:

#oc logs curator-1591002600-2nrz8
Traceback (most recent call last):
  File "/opt/app-root/src/lib/oalconverter/convert.py", line 18, in <module>
    from ruamel import yaml
ModuleNotFoundError: No module named 'ruamel'
Usage: curator [OPTIONS] ACTION_FILE


Version-Release number of selected component (if applicable):
openshift/ose-logging-curator5:v4.5.0-202005302117


How reproducible:
Always

Steps to Reproduce:
1. Deploy clusterlogging 4.5.0
2. Check the curator pod logs

Actual results:


Expected results:


Additional info:

--- Additional comment from Jeff Cantrill on 2020-06-01 15:03:42 UTC ---

Can you provide the image that demonstrates this?

Comment 4 Anping Li 2020-06-04 15:43:45 UTC
Verified using CI images

Comment 6 errata-xmlrpc 2020-10-27 16:03:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.