Bug 184283 - lvremove traceback on ppc install
lvremove traceback on ppc install
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2006-03-07 15:31 EST by Orion Poplawski
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-03-16 12:22:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Full anaconda dump log (134.86 KB, text/plain)
2006-03-07 15:31 EST, Orion Poplawski
no flags Details

  None (edit)
Description Orion Poplawski 2006-03-07 15:31:57 EST
Description of problem:

Trying to install today's (20060307) rawhide on Mac Mini via NFS/Kickstart.

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 1218, in ?
    intf.run(id, dispatch)
  File "/usr/lib/anaconda/text.py", line 535, in run
  File "/usr/lib/anaconda/dispatch.py", line 146, in gotoNext
  File "/usr/lib/anaconda/dispatch.py", line 217, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 151, in turnOnFilesystems
  File "/usr/lib/anaconda/partitions.py", line 1283, in doMetaDeletes
    lvm.lvremove(name, vg)
  File "/usr/lib/anaconda/lvm.py", line 145, in lvremove
    raise SystemError, "lvremove failed"
SystemError: lvremove failed

Local variables in innermost frame:
lvname: var
vgname: rootvg
args: ['lvm', 'lvremove', '-f', '/dev/rootvg/var']
dev: /dev/rootvg/var
rc: 1280

nfs --server=saga --dir=/export/data1/fedora/core/5/ppc/os
lang en_US.UTF-8
keyboard us
network --bootproto=dhcp
rootpw --iscrypted CwU/lYtazWt7E
firewall --disabled
selinux --enforcing
authconfig --enableshadow --enablenis --nisdomain=yp.colorado-research.com
timezone America/Denver
xconfig --startxonboot --defaultdesktop=KDE --resolution=1600x1200 --depth=24
clearpart --linux
part appleboot --fstype "Apple Bootstrap" --size=1 --maxsize=1
part /boot --fstype ext3 --size=50
part pv.1 --size=1 --grow
volgroup rootvg pv.1
logvol / --vgname=rootvg --size=512 --name=root
logvol swap --fstype=swap --vgname=rootvg --recommended --name=swap
logvol /usr --vgname=rootvg --size=4000 --name=usr
logvol /var --vgname=rootvg --size=512 --name=var
logvol /export/data1 --vgname=rootvg --size=1 --name=data1 --grow
bootloader --location=mbr
Comment 1 Orion Poplawski 2006-03-07 15:31:57 EST
Created attachment 125773 [details]
Full anaconda dump log
Comment 2 Orion Poplawski 2006-03-08 12:54:04 EST
Running "lvm lvremove -f /dev/rootvg/var" in the F2 console gives:

File descriptor 20 left open
File descriptor 22 left open
File descriptor 26 left open
File descriptor 29 left open
File descriptor 30 left open
File descriptor 34 left open
  Inconsistent metadata copies found - updating to use version 17
  Volume group rootvg metadata is inconsistent
  Volume group for uuid not found:
  Unable to deactivate logical volume "var"

I can no longer boot my old FC4 system due to Volume group "rootvg" inconsistent

Since my kickstart file indicates to clear all linux partitions, I'm not sure
why it's bothering to remove the logical volumes.  Why not just deactivate them
and delete the partition?
Comment 3 Orion Poplawski 2006-03-14 18:17:27 EST
Great, we get to fight over whether this is an anaconda bug or an lvm bug. 
Probably both...

Ok, wiped the partition and did a fresh fc4 install.  Then did an upgrade to the
latest rawhide.  Now trying to do a reinstall of latest rawhide over top with
the above kickstart and get the same error (though on /dev/rootvg/data1 this time).

Why are we removing logical volumes and not clearing partitions?  Why is lvm
corrupting what was a perfectly good volume group?

Oh well, not much worse than the FC4 bug where you had to boot the installer
twice to clear partions, though this time you have to do it manually (but may
only be on ppc).
Comment 4 Orion Poplawski 2006-03-16 12:22:00 EST
Install with today's rawhide worked.  Looks like anaconda may not be doing a lvm
remove any more.  In any case, it's fixed.

Note You need to log in before you can comment on or make changes to this bug.