Bug 1842871 - [oVirt] template temporary VM is created with no tag
Summary: [oVirt] template temporary VM is created with no tag
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: ---
: 4.6.0
Assignee: Gal Zaidman
QA Contact: Guilherme Santos
URL:
Whiteboard:
: 1805599 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-02 09:29 UTC by Gal Zaidman
Modified: 2020-10-27 16:04 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:03:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 3868 0 None closed ovirt: tag and remove tmp/bootstrap machines 2021-01-18 16:53:43 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:04:20 UTC

Description Gal Zaidman 2020-06-02 09:29:31 UTC
Description of problem:

When the ovirt installer creates a template it first creates a temporary VM which is used to create the template. The temporary VM is created with no ovirt tag on it, and therefor it will not be removed on cluster destroy


Steps to Reproduce:
1. Run the installer with no template override.
2. Run `openshift-install destroy cluster`
3. Look at the engine VMs and see that the top VM is still there.

Actual results:
- tmp VM is not removed if present on cluster destroy.

Expected results:
- tmp VM should be removed if present on cluster destroy.

Comment 1 Douglas Schilling Landgraf 2020-06-05 14:48:05 UTC
*** Bug 1805599 has been marked as a duplicate of this bug. ***

Comment 2 Gal Zaidman 2020-06-17 16:18:59 UTC
due to capacity constraints we will be revisiting this bug in the upcoming sprint

Comment 3 Douglas Schilling Landgraf 2020-07-09 12:12:00 UTC
due to capacity constraints we will be revisiting this bug in the upcoming sprint

Comment 4 Douglas Schilling Landgraf 2020-07-15 14:54:02 UTC
This bug is about cluster destroy, moving to MODIFIED.

Comment 7 Guilherme Santos 2020-07-22 12:55:30 UTC
Verified on:
4.6.0-0.nightly-2020-07-22-074636

Steps:
1. # openshift-install create cluster --log-level=debug --dir=resources
2. # openshift-install destroy cluster --dir=resources
3. check on engine UI if tmp vm is there (Compute -> Virtual Machines)

Results:
tmp vm deleted

Comment 9 errata-xmlrpc 2020-10-27 16:03:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.