Bug 184299 - no sound at an Acer Aspire 3002LCi
no sound at an Acer Aspire 3002LCi
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
: Desktop
Depends On:
Blocks: 183415
  Show dependency treegraph
 
Reported: 2006-03-07 16:43 EST by Suzanne Hillman
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-30 05:25:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logfile created by system-config-soundcard after failure to hear sound, on aspire (10.38 KB, text/plain)
2006-03-07 16:43 EST, Suzanne Hillman
no flags Details

  None (edit)
Description Suzanne Hillman 2006-03-07 16:43:15 EST
Description of problem:
Automatic detection of the sound card did not work on an Acer Aspire 3002LCi
with the latest rawhide, either as part of the install (firstboot, I believe?),
or when system-config-soundcard was run after the install was complete.

Version-Release number of selected component (if applicable):
system-config-soundcard-1.2.16-2 (not sure what else you need)

How reproducible:
Always

Steps to Reproduce:
1. Run system-config-soundcard, and hit the play button to test the sound
2. No sound comes out, and when you tell it so after it asks, it creates a log
file which I will attach.
  
Actual results:
No sound.

Expected results:
Sound should work.

Additional info:
Comment 1 Suzanne Hillman 2006-03-07 16:43:16 EST
Created attachment 125778 [details]
logfile created by system-config-soundcard after failure to hear sound, on aspire
Comment 2 Martin Stransky 2006-03-08 05:32:00 EST
Everything looks fine, you can check some mixer settings (you should use
alsamixer utility) like "External amplifier" and so on...
Comment 3 Suzanne Hillman 2006-03-08 11:05:35 EST
Ok, that's interesting. Why would having the volume showing up in the middle of
the volume level setting not have any sound? I'd not tried upping the volumne,
since I didn't expect mid-point to equal silent.

Is this something you would be working on, or does it need reassigning?
Comment 4 Suzanne Hillman 2006-03-08 11:09:33 EST
(happens on a fujitsu lifebook, too)
Comment 5 Martin Stransky 2006-03-08 12:02:02 EST
Just do what I ask you for...
Comment 6 Suzanne Hillman 2006-03-08 13:30:43 EST
I have no idea how to use the mixer utility you suggested I use, so that's
rather difficult to do. Starting it works, but I don't know what keystrokes to
use to actually do anything.
Comment 7 Suzanne Hillman 2006-03-08 14:51:16 EST
If you open the graphical version of the mixer program, while
system-config-soundcard is up, and move the volume slider of the s-c-s, it moves
both the Master and the PCM input sliders in the volume control window. It
should be only affecting the Master one, like the volume button on the panel does.

I suspect that this inadvertant association with both Master and PCM is where
the problem is coming from.

(this is also true if one watches the behavior in alsamixer, which I can check
without knowing the necessary keystrokes)
Comment 8 Martin Stransky 2006-03-09 03:16:06 EST
alsamixer is a command line utility, run it from a terminal. External amplifier
is a switch (not adjustment) and you can check some other switches, too.
Comment 9 Suzanne Hillman 2006-03-09 10:39:29 EST
Yes. I ran it. However, starting it is not the same as having any idea how to
interact with it once it's been started.

I have no idea what you want me to _do_ with it once it's started, and I cannot
figure out which switch to use to get the external amplifier (the man page
mentions nothing about that). Do you want the value of the external amplifier?
Something else?

And - is running it actually useful at this point, considering what I found in
comment #7?

Additionally, have you checked if this is happening on machines you have
locally, with rawhide from both two days ago and yesterday? I suspect that it
likely is, and doesn't actually require you to be trying to have me debug it via
bugzilla.
Comment 10 Martin Stransky 2006-03-10 10:35:23 EST
Use the 'm' key to mute/unmute some channel. I don't have your hardware so there
isn't any other way how I can do something with this. btw. everything looks fine
so I think the problem can be only with mixer settings. It's very
hardware-specific problem and on my box everything works fine, of course.
Comment 11 Suzanne Hillman 2006-03-10 11:13:08 EST
I'm skeptical that it's a question of muting and unmuting, since increasing the
volume from the midpoint of the slider in s-c-s _does_ make the sound audible.
Also, changing the mute setting has no effect (it was not set to mute initially,
if nothing else), which is something I'd already checked with the graphical
mixer tool that I did know how to use.

You have verified that there isn't some code somewhere accidentally causing
s-c-s's volume slider to be affecting more than one input source? The Acer has
it affect both Master and PCM, and the Fujitsu has it affecting both the Volume
and CD.
Comment 12 Martin Stransky 2006-03-10 11:31:12 EST
s-c-s's volume slider has to affect all available volume controls because I
can't tell which slider exactly affect your hardware configuration (if you can
use headphones I have to increase headphone control, if you use some external
speakers, I have to increase these). It's a general problem with ALSA mixer and
I'm afraid that nobody from RH can solve it...
Comment 13 Suzanne Hillman 2006-03-10 13:34:27 EST
Hmm.

It doesn't seem to be affecting all of them, actually. And I'm fairly sure that
there are cases where there is any sound at all when one hasn't yet touched the
volume slider. So perhaps it's not this, although it certainly seemed to be.

So, keeping in mind that nothing was muted, any other suggestions as to what I
should look at?
Comment 14 Martin Stransky 2006-03-13 02:01:51 EST
There can be a bug with "no sound w/o touching any volume slider in s-c-s". You
can reproduce this bug simply - remove /etc/asound.state, reboot your box and
run s-c-s. All channels are muted after boot, s-c-s should adjust volume to 60%
for all playback channels and sound should be audible w/o touching the slider...
Comment 15 Martin Stransky 2006-03-13 08:58:14 EST
I'm sorry, you need to unload all sound modules before deleting
/etc/asound.state. You can use modprobe for it:

# modprobe -r snd_intel8x0
# modprobe -r snd_intel8x0m

if modprobe complains to using this modules, switch to runlevel 3 first:

#init 3

and check modprobe again. Then you can delete /etc/asound.state and reboot your box.
Comment 16 Suzanne Hillman 2006-03-13 11:39:05 EST
Are you telling me that you can now reproduce this? If so, then I'm not sure why
you're telling me how to do so, since I can't actually fix the problem. :)

If you're asking if this is the same problem, then yes, it looks like the same
thing.
Comment 17 Martin Stransky 2006-03-14 03:33:43 EST
You're close. As you said:

"And I'm fairly sure that
there are cases where there is any sound at all when one hasn't yet touched the
volume slider. So perhaps it's not this, although it certainly seemed to be."

So I told you how you could check it. I repeat again I can't reproduce this bug,
it works fine for me and if I should to fix it I need some feedback.

Note You need to log in before you can comment on or make changes to this bug.