Bug 1843059 - CAM operator fails to install via non-olm v1.2.0 operator.yml file
Summary: CAM operator fails to install via non-olm v1.2.0 operator.yml file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Migration Tooling
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.z
Assignee: Erik Nelson
QA Contact: Xin jiang
URL:
Whiteboard:
Depends On: 1843058
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-02 16:50 UTC by Erik Nelson
Modified: 2020-06-04 11:14 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1843058
Environment:
Last Closed: 2020-06-04 11:14:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:2386 None None None 2020-06-04 11:14:55 UTC

Description Erik Nelson 2020-06-02 16:50:24 UTC
+++ This bug was initially created as a clone of Bug #1843058 +++

Description of problem:
CAM operator fails to install via the non-olm v1.2.0 operator.yml file that's exported off of the operator image for installation in 3.x clusters.

Version-Release number of selected component (if applicable):
1.2.0

How reproducible:
Every time

Steps to Reproduce:
1. Login to OCP 3.x cluster
2. podman cp $(podman create registry.redhat.io/rhcam-1-2/openshift-migration-rhel7-operator:v1.2):/operator.yml ./ && oc create -f ./operator.yml

Actual results:
Deployment fails to create with the following error:

Error from server (Invalid): error when creating "./operator.yml": Deployment.apps "migration-operator" is invalid: spec.template.spec.containers[1].env[6].name: Required value

https://github.com/konveyor/mig-operator/pull/361 shows the problem and the fix, which has been merged to master.

Expected results:
Operator should install

Comment 3 Erik Nelson 2020-06-03 13:12:57 UTC
Issue fixed by the following PR in the release-1.2.1 branch: https://github.com/konveyor/mig-operator/pull/361

Comment 4 Sergio 2020-06-03 20:07:01 UTC
Verified in CAM 1.2.1 stage

openshift-migration-rhel7-operator@sha256:f9092d108e839bdeec85634e0306c4b9206f391167234058c14386ddfd21b39c

Installed in 3.11 without problems. Migrations could be run without problems too.

Comment 6 errata-xmlrpc 2020-06-04 11:14:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2386


Note You need to log in before you can comment on or make changes to this bug.