Bug 1843174 - dnf uninstallable in Fedora Rawhide Koji
Summary: dnf uninstallable in Fedora Rawhide Koji
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: libdnf
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: TRACKER-bugs-affecting-libguestfs F33FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2020-06-02 18:18 UTC by Richard W.M. Jones
Modified: 2020-06-03 10:45 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-03 03:41:19 UTC
Type: Bug


Attachments (Terms of Use)

Description Richard W.M. Jones 2020-06-02 18:18:56 UTC
Description of problem:

DEBUG util.py:600:  Error: 
DEBUG util.py:600:   Problem: package python3-dnf-4.2.21-2.fc33.noarch requires python3-hawkey >= 0.46.2, but none of the providers can be installed
DEBUG util.py:600:    - package python3-hawkey-0.48.0-1.fc33.x86_64 conflicts with python3-dnf < 4.2.23 provided by python3-dnf-4.2.21-2.fc33.noarch
DEBUG util.py:600:    - package dnf-4.2.21-2.fc33.noarch requires python3-dnf = 4.2.21-2.fc33, but none of the providers can be installed
DEBUG util.py:600:    - package supermin-5.2.0-2.fc33.x86_64 requires dnf, but none of the providers can be installed
DEBUG util.py:600:    - package libguestfs-1:1.42.0-7.fc33.x86_64 requires supermin >= 5.1.18, but none of the providers can be installed
DEBUG util.py:600:    - package libguestfs-devel-1:1.42.0-7.fc33.x86_64 requires libguestfs.so.0()(64bit), but none of the providers can be installed
DEBUG util.py:600:    - package libguestfs-devel-1:1.42.0-7.fc33.x86_64 requires libguestfs(x86-64) = 1:1.42.0-7.fc33, but none of the providers can be installed
DEBUG util.py:600:    - conflicting requests

Full log here:
https://koji.fedoraproject.org/koji/taskinfo?taskID=45322705

Version-Release number of selected component (if applicable):

python3-dnf-4.2.21-2.fc33.noarch

How reproducible:

100%

Steps to Reproduce:
1. Build any package that BR's dnf.

Additional info:

Comment 2 Richard W.M. Jones 2020-06-02 18:48:21 UTC
Thanks, I will try it out as soon as the build is available in Koji.

Comment 3 Richard W.M. Jones 2020-06-02 18:58:00 UTC
I guess it's using the new version but still couldn't build:
https://koji.fedoraproject.org/koji/taskinfo?taskID=45325885

What's really odd is that "libdnf" appears nowhere in the root.log.

Comment 4 Miro Hrončok 2020-06-02 21:05:45 UTC
The commit I've linked is not the fix, but the cause.

libdnf produces python3-hawkey

Comment 5 Kevin Fenzi 2020-06-02 21:46:42 UTC
Should we untag the latest libdnf here? Or is there more interdependent packages that would be broken by that?

Comment 6 Igor Raits 2020-06-03 03:41:19 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (ignatenkobrain@fedoraproject.org).

All subpackages of a package agaisnt which this bug was filled are now installable or removed from Fedora 33.

Thanks for taking care of it!

Comment 7 amatej 2020-06-03 06:11:58 UTC
Sorry, this was my bad. We didn't build all the packages as soon as we could, so the transition period was longer. 
In fact thank you Igor for building the new dnf-plugins-core.  

Unfortunately the dependencies worked out that new libdnf conflicts with older dnf and new dnf conflicts with older dnf-plugins-core.

Comment 8 Richard W.M. Jones 2020-06-03 10:45:40 UTC
Can confirm it works now.


Note You need to log in before you can comment on or make changes to this bug.