Bug 1843532 - VM reports status Off when DVs are still being imported [NEEDINFO]
Summary: VM reports status Off when DVs are still being imported
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Phillip Bailey
QA Contact: Guohua Ouyang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-03 13:38 UTC by Radim Hrazdil
Modified: 2020-10-27 16:05 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:04:47 UTC
Target Upstream Version:
tjelinek: needinfo? (mcarleto)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6323 0 None closed Bug 1843532: Fix VM import status reporting for CDI imports 2020-10-15 12:15:25 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:05:18 UTC

Description Radim Hrazdil 2020-06-03 13:38:51 UTC
Description of problem:


Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-06-02-220939

How reproducible:
100

Steps to Reproduce:
1. Create a VM from URL source, do not click start after creation
2. Navigate to detail
    => VM is in Off state
3. Start VM
    => VM is in Pending state


Expected results:
VM should report Importing

Comment 2 Guohua Ouyang 2020-06-24 02:36:06 UTC
is "Importing" is used for importing VM from RHV/VMware, can we use a word to distinct from importing VM from RHV/VMware?

Comment 3 Tomas Jelinek 2020-06-24 05:48:38 UTC
@Matt: hmmm, do you think it is a problem to call it "importing" both for v2v import from RHV/VMware and CDI import from an URL?

Comment 4 Guohua Ouyang 2020-07-02 02:41:02 UTC
In my opinion, if there is no difference between "CDI import" from "RHV/Vmware import", we can place "URL" into "Import with Wizard", not "New with Wizard".
It's better to differentiate them.

Comment 5 Phillip Bailey 2020-07-06 15:21:16 UTC
Yaacov pointed out that we're also discussing the differentiation of the terminology issue in https://bugzilla.redhat.com/show_bug.cgi?id=1849555. The KubeVirt docs [1] use the term "import" and the CDI README [2][3] specifies importing by source. Yaacov and I think we should remain consistent with them and specify the import source, such as "Importing from URL", "Importing from VMWare", etc. If we can all agree on that, it will still leave the question of whether URL import should be in the import wizard instead of the create wizard. Filip, what do you think?


[1] https://kubevirt.io/2018/containerized-data-importer.html
[2] https://github.com/kubevirt/containerized-data-importer#import-from-ovirt
[3] https://github.com/kubevirt/containerized-data-importer#import-from-url

Comment 6 Filip Krepinsky 2020-07-09 12:24:17 UTC
The main difference is that we are importing a VM from VMware/RHV and in case URL import it is just one DV/PVC. This complicate matters even mores since you can add such http DV/PVC to any artificial source in the wizard. So having a special wizard for that would not accomplish much IMO.

I am not against a different or more detailed naming, but I still think it is clear what is going on to some degree.

The current scheme
Importing (RHV)
Importing (VMware) 
Importing (CDI)  - this is meant for all imports http, pvc, blank, 

or Import error (RHV), Import pending (RHV), etc.


Ofc, you can still see more details in the popup when you click the on the status - we can also work on that - what information we want to display there

Comment 7 Tomas Jelinek 2020-07-10 06:57:27 UTC
We fixed some bugs last sprint, did not have capacity to fix this one. Setting upcoming sprint.

Comment 10 Guohua Ouyang 2020-09-15 06:48:27 UTC
verified on 4.6.0-fc.4

Comment 12 errata-xmlrpc 2020-10-27 16:04:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.