Bug 1843599 - command line terminal stuck loading for user with access to multiple namespaces
Summary: command line terminal stuck loading for user with access to multiple namespaces
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.6.0
Assignee: cvogt
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks: 1843661
TreeView+ depends on / blocked
 
Reported: 2020-06-03 16:01 UTC by cvogt
Modified: 2020-10-27 16:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:04:47 UTC
Target Upstream Version:


Attachments (Terms of Use)
command line terminal doesn't stuck loading for user with access to multiple namespaces (851.94 KB, video/webm)
2020-06-07 18:44 UTC, spathak@redhat.com
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5652 0 None closed Bug 1843599: cloudshell: fix loading loop for user with multiple projects 2020-06-19 13:57:15 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:05:18 UTC

Description cvogt 2020-06-03 16:01:43 UTC
Description of problem:
If a user has multiple projects and they do not have cluster scope access to list projects, the command line terminal drawer shows a loading indicator.


Version-Release number of selected component (if applicable):
4.5


How reproducible:


Steps to Reproduce:
1. Install the che-workspace-operator:

git clone https://github.com/che-incubator/che-workspace-operator
export WEBHOOK_ENABLED=true
export REGISTRY_ENABLED=false
make deploy

2. Login as a self-provisioner user
3. Create 2 namespaces
4. Click the command line terminal button in the masthead

Actual results:
Terminal drawer opens and shows a loading indicator.

Expected results:
Terminal drawer opens and after a second the loading indicator should disappear and show a form for the user to select a namespace to create the Workspace in.

Comment 1 cvogt 2020-06-03 16:44:19 UTC
High severity because a new high visibility feature will not be accessible for a typical user.

Comment 5 spathak@redhat.com 2020-06-07 18:44:34 UTC
Created attachment 1695896 [details]
command line terminal doesn't stuck loading for user with access to multiple namespaces

Comment 6 spathak@redhat.com 2020-06-07 18:47:03 UTC
Verified on build version: 4.5.0-0.nightly-2020-06-06-160933
Browser version: Chrome 76

Comment 8 errata-xmlrpc 2020-10-27 16:04:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.