Bug 184366 - Forecast missing for Cambridge, UK.
Summary: Forecast missing for Cambridge, UK.
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-applets   
(Show other bugs)
Version: 7
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-08 09:35 UTC by David Woodhouse
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-17 15:55:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 467697 None None None Never

Description David Woodhouse 2006-03-08 09:35:27 UTC
The weather applet tells me that no forecast is available. It lies -- I could
get one from http://www.meto.gov.uk/lib/includes/fsssi/city/cambridge.html

I don't see a way to tell it that though.

Comment 1 David Woodhouse 2006-04-03 12:32:01 UTC
Same problem in FC5. Still no way to tell it that I know where the forecast is.


Comment 2 Alex Kloss 2006-05-17 22:35:07 UTC
I have tested this on GNOME version 2.14.1 and was able to receive a forecast 
for Cambridge. If this problem persists, try to update the applet by right-
clicking on the applet and selecting "Update".

Comment 3 David Woodhouse 2006-05-17 22:44:12 UTC
Reassigning to gnome-applets.

Comment 4 David Woodhouse 2006-05-17 22:48:30 UTC
I still get "Forecast not currently available for this location."

If I change it to London, I get a forecast. Changing it _back_ to Cambridge then
does give a forecast.

Comment 5 Ray Strode [halfline] 2007-08-15 21:02:06 UTC
Sorry for the slow turnaround on this one, guys.  Is this still an issue?

Comment 6 David Woodhouse 2007-08-17 02:49:31 UTC
Still says 'Forecast not currently available for this location', and no way to
tell it to look at
http://www.metoffice.gov.uk/weather/uk/ee/cambridge_forecast_weather.html

I have no recollection of the events related in comment #4. I don't remember
ever seeing it give a forecast, although current weather has always worked. I
don't see how I would have come to make it up though; I assume it really happened :)

Comment 7 Ray Strode [halfline] 2007-08-17 15:48:44 UTC
So there are a few problems it looks like:

First, the url changed.  gweather applet tries to go to:

http://www.metoffice.gov.uk/weather/europe/uk/eastern.html
for cambridge, but the new url is:
http://www.metoffice.gov.uk/weather/uk/ee/ee_forecast_weather.html (as you point
out above)

If I go to the first url in firefox it takes me to the second url. 

gnome_vfs_async_open just returns NOT_FOUND, however, for the first url instead
of redirecting.  /usr/bin/HEAD doesn't mention any sort of redirect so something
strange is going on, but I haven't looked too deeply.

Aside from that, the actual content of the page has changed as well.  It now
stores the forecast in some weird javascript/dhtml setup that's harder to
screen-scrape.

Anyway, it would take me quite a bit of time to get this working, unfortunately,
and I don't have that time to invest right now.  I was hoping this would just be
a Locations.xml change or some such that I could commit and build in between my
other work.

I'll file it upstream for you and maybe someone else will look into it.


Comment 8 Ray Strode [halfline] 2007-08-17 15:55:40 UTC
Filed here:
http://bugzilla.gnome.org/show_bug.cgi?id=467697

closing UPSTREAM

Comment 9 David Woodhouse 2007-08-18 01:54:54 UTC
Perhaps the BBC version would be better. They seem to be better set up for it,
with RSS feeds etc. 

http://www.bbc.co.uk/weather/5day.shtml?id=1413
http://feeds.bbc.co.uk/weather/feeds/rss/5day/id/1413.xml


Note You need to log in before you can comment on or make changes to this bug.