Bug 1843705 - registry-server fails to start on systems where /tmp is unavailable
Summary: registry-server fails to start on systems where /tmp is unavailable
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.5.0
Assignee: Evan Cordell
QA Contact: Salvatore Colangelo
URL:
Whiteboard:
: 1846016 (view as bug list)
Depends On: 1843702
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-03 21:24 UTC by Nick Hale
Modified: 2020-07-13 17:43 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1843702
Environment:
Last Closed: 2020-07-13 17:43:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github operator-framework operator-registry pull 355 None closed [release-4.5] Bug 1843705: fix(copy): make tmpdir relative to current directory 2020-07-29 08:30:20 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:43:28 UTC

Internal Links: 1847415

Comment 2 Bowen Song 2020-06-11 13:51:28 UTC
duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1846016 which is for 4.5 already. No need to wait for 4.5.z

*** This bug has been marked as a duplicate of bug 1846016 ***

Comment 3 Evan Cordell 2020-06-15 14:28:27 UTC
*** Bug 1846016 has been marked as a duplicate of this bug. ***

Comment 7 Salvatore Colangelo 2020-06-22 12:12:17 UTC
1 run the `index add`

[scolange@scolange operator-registry]$ ./opm index add -b quay.io/olmqe/etcd-bundle:0.9.0 -t quay.io/olmqe/etcd-index:1843702
INFO[0000] building the index                            bundles="[quay.io/olmqe/etcd-bundle:0.9.0]"
INFO[0000] resolved name: quay.io/olmqe/etcd-bundle:0.9.0 
INFO[0000] fetched                                       digest="sha256:df6e623ed57f46c4ff80fd2fb027859986066570f7e6aae6435cd74908ed3333"
INFO[0001] fetched                                       digest="sha256:b107658da605b5721c34b3fc2abf9e6515aba4d0a7020e407131f783d77148f3"
INFO[0001] fetched                                       digest="sha256:e2e833ebbda87e017110ab08bd2c03b46540409d9014e4685d2736e206caf0f2"
INFO[0001] fetched                                       digest="sha256:78a6cdfac35dc99cea2ae6e012ddd6d556c163ecf55e694767efb1593f1eeb2c"
INFO[0002] unpacking layer: {application/vnd.docker.image.rootfs.diff.tar.gzip sha256:78a6cdfac35dc99cea2ae6e012ddd6d556c163ecf55e694767efb1593f1eeb2c 8006 [] map[] <nil>} 
INFO[0002] unpacking layer: {application/vnd.docker.image.rootfs.diff.tar.gzip sha256:b107658da605b5721c34b3fc2abf9e6515aba4d0a7020e407131f783d77148f3 260 [] map[] <nil>} 
INFO[0002] Could not find optional dependencies file     dir=bundle_tmp720890181 file=bundle_tmp720890181/metadata load=annotations
INFO[0002] found csv, loading bundle                     dir=bundle_tmp720890181 file=bundle_tmp720890181/manifests load=bundle
INFO[0002] loading bundle file                           dir=bundle_tmp720890181/manifests file=etcdbackups.etcd.database.coreos.com.crd.yaml load=bundle
INFO[0002] loading bundle file                           dir=bundle_tmp720890181/manifests file=etcdclusters.etcd.database.coreos.com.crd.yaml load=bundle
INFO[0002] loading bundle file                           dir=bundle_tmp720890181/manifests file=etcdoperator.v0.9.0.clusterserviceversion.yaml load=bundle
INFO[0002] loading bundle file                           dir=bundle_tmp720890181/manifests file=etcdrestores.etcd.database.coreos.com.crd.yaml load=bundle
INFO[0002] Generating dockerfile                         bundles="[quay.io/olmqe/etcd-bundle:0.9.0]"
INFO[0002] writing dockerfile: index.Dockerfile588315227  bundles="[quay.io/olmqe/etcd-bundle:0.9.0]"
INFO[0002] running podman build                          bundles="[quay.io/olmqe/etcd-bundle:0.9.0]"
INFO[0002] [podman build -f index.Dockerfile588315227 -t quay.io/olmqe/etcd-index:1843702 .]  bundles="[quay.io/olmqe/etcd-bundle:0.9.0]"


2. Run the podman command, it works well, LGTM, verify it.
[scolange@scolange operator-registry]$ sudo podman run -ti quay.io/olmqe/etcd-index:1843702
time="2020-06-22T12:11:13Z" level=info msg="serving registry" database=/database/index.db port=50051

Comment 8 errata-xmlrpc 2020-07-13 17:43:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.