Bug 184372 - modality level of message boxes might cause problems
modality level of message boxes might cause problems
Status: CLOSED DUPLICATE of bug 184371
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
Depends On:
  Show dependency treegraph
Reported: 2006-03-08 05:15 EST by Juergen Bullinger
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-03-09 02:07:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Juergen Bullinger 2006-03-08 05:15:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; de; rv: Gecko/20060306 Fedora/ Firefox/

Description of problem:
If a message box appears like when you open the email editor to send a new email, enter something and close it using the system menu, the message seems to be application- or system modal (i don't know the correct term).
This means that all other evolution windows are blocked until this message is closed, but you still can switch to other evolution windows (and move the message window in the background).
If you have a lot of such windows open it is hard to find the one with the message.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. open evolution
2. open several evolution windows (e.g. to read messages in your inbox etc.) => don't start evolution multiple times, just open some child windows
3. cause a situation where a message pops up (e.g. by creating a new mail and closing it using the system menu close button in the upper right corner of the window)
4. switch to other evolution windows


Actual Results:  It is possible to switch to another evolution window, but it is "frozen" because of the modality

Expected Results:  Either it should not switch to other windows of evolution (e.g. always popup the message again)


change the "modality level" so that only the window causing the problem "freezes". (i guess it is system modal <-> application modal)

To me the second sounds better, but maybe it is not applicable.

Additional info:

Ok one might think if a user is that stupid to move some window in the backround it's their own fault, but if this happens for all message maybe also the automatic mail download each 10 Minutes could cause such a situation and probably the user wouldn't recognize this until he checked all evolution windows.

The situation really looks like evolution needs a 

killall evolution -KILL

I must admit, that I already did that :o)
Comment 1 Frank Arnold 2006-03-09 02:07:29 EST

*** This bug has been marked as a duplicate of 184371 ***

Note You need to log in before you can comment on or make changes to this bug.