Bug 1843756 - "Pod error" is not good enough for VM status
Summary: "Pod error" is not good enough for VM status
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Yaacov Zamir
QA Contact: Guohua Ouyang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-04 03:32 UTC by Guohua Ouyang
Modified: 2020-10-27 16:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:04:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5808 0 None closed Bug 1843756: Pod error to launcher pod error 2020-06-30 10:21:22 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:05:14 UTC

Description Guohua Ouyang 2020-06-04 03:32:03 UTC
Description of problem:
When VM is failed to start, the status shows "Pod error", but its contents includes "VM events" and "Pod logs", it makes "Pod error" not looking good.

Another reason as it's VM failure, shows a "Pod error" is a bit confuse even though it's root cause is the pod cannot be started.

I would suggest to change it to "VM error" or "Launch error".

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-05-30-015116

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Guohua Ouyang 2020-06-30 10:24:43 UTC
It's "Launcher pod error" on upstream 4.6 branch.

Comment 5 errata-xmlrpc 2020-10-27 16:04:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.