Bug 1843929 - oc kustomize help shows kubectl instead oc
Summary: oc kustomize help shows kubectl instead oc
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.5
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.6.0
Assignee: Maciej Szulik
QA Contact: zhou ying
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-04 12:43 UTC by Eduardo Minguez
Modified: 2020-10-27 16:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:04:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift oc pull 453 0 None closed Bug 1843929: use wrapper for kustomize sub-command 2020-07-14 01:27:18 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:05:14 UTC

Description Eduardo Minguez 2020-06-04 12:43:01 UTC
Description of problem:
oc kustomize -h shows kubectl instead.

Version-Release number of selected component (if applicable):

$ oc version
Client Version: 4.5.0-0.nightly-2020-06-04-025914
Server Version: 4.5.0-0.nightly-2020-06-04-025914
Kubernetes Version: v1.18.3+a637491

How reproducible:
Run `oc kustomize -h` with 4.5.0-0.nightly-2020-06-04-025914

Steps to Reproduce:
1.
2.
3.

Actual results:
```
Print a set of API resources generated from instructions in a kustomization.yaml file.

 The argument must be the path to the directory containing the file, or a git repository URL with a path suffix
specifying same with respect to the repository root.

 kubectl kustomize somedir

Usage:
  oc kustomize <dir> [flags]

Examples:
  # Use the current working directory
  kubectl kustomize .
  
  # Use some shared configuration directory
  kubectl kustomize /home/configuration/production
  
  # Use a URL
  kubectl kustomize github.com/kubernetes-sigs/kustomize.git/examples/helloWorld?ref=v1.0.6

Use "oc options" for a list of global command-line options (applies to all commands).
```

Expected results:
Same output but using `oc` instead `kubectl`

Additional info:

Comment 3 zhou ying 2020-06-11 08:11:01 UTC
[root@dhcp-140-138 verification-tests]# oc kustomize -h
Print a set of API resources generated from instructions in a kustomization.yaml file.

 The argument must be the path to the directory containing the file, or a git repository URL with a path suffix
specifying same with respect to the repository root.

 oc kustomize somedir

Usage:
  oc kustomize <dir> [flags]

Examples:
  # Use the current working directory
  oc kustomize .
  
  # Use some shared configuration directory
  oc kustomize /home/configuration/production
  
  # Use a URL
  oc kustomize github.com/kubernetes-sigs/kustomize.git/examples/helloWorld?ref=v1.0.6

Use "oc options" for a list of global command-line options (applies to all commands).


[root@dhcp-140-138 verification-tests]# oc version 
Client Version: 4.6.0-202006092217-f30826e
Kubernetes Version: v1.18.3+91d0edd

Comment 5 errata-xmlrpc 2020-10-27 16:04:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.