Bug 1843932 - RHEL8 installation with CIS security policy and "Server with GUI" group of packages aborts
Summary: RHEL8 installation with CIS security policy and "Server with GUI" group of pa...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: oscap-anaconda-addon
Version: 8.3
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 8.0
Assignee: Matěj Týč
QA Contact: Release Test Team
Mirek Jahoda
URL:
Whiteboard:
Depends On: 1839769
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-04 12:49 UTC by Matus Marhefka
Modified: 2021-05-17 12:57 UTC (History)
9 users (show)

Fixed In Version: oscap-anaconda-addon-1.1.1-2.el8
Doc Type: Known Issue
Doc Text:
.Installation with the `Server with GUI` or `Workstation` software selections and CIS security profile is not possible The CIS security profile is not compatible with the `Server with GUI` and `Workstation` software selections. As a consequence, a RHEL 8 installation with the `Server with GUI` software selection and CIS profile is not possible. An attempted installation using the CIS profile and either of these software selections will generate the error message: ---- package xorg-x11-server-common has been added to the list of excluded packages, but it can't be removed from the current software selection without breaking the installation. ---- To work around the problem, do not use the CIS security profile with the `Server with GUI` or `Workstation` software selections.
Clone Of:
Environment:
Last Closed: 2020-11-04 03:46:16 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description Matus Marhefka 2020-06-04 12:49:10 UTC
Description of problem:
Installation of RHEL8 "Server with GUI" with CIS as security policy is not possible and it is aborted due to package conflicts. The issue is most likely caused by rule "package_xorg-x11-server-common_removed" which is selected in CIS profile. More details can be found in the https://github.com/ComplianceAsCode/content/issues/5746


Version-Release number of selected component (if applicable):
scap-security-guide-0.1.50-4.el8


How reproducible:
always


Steps to Reproduce:
1. Select "Server with GUI" package group and CIS security policy when installing RHEL8.
2. Start installation.


Actual results:
Installation fails on package conflicts.


Expected results:
Installation is successful.


Additional info:
https://github.com/ComplianceAsCode/content/issues/5746

Comment 1 Matěj Týč 2020-06-17 13:47:54 UTC
Moving to oscap-anaconda-addon, as the failure of the installation is not content's fault.

Comment 14 errata-xmlrpc 2020-11-04 03:46:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (oscap-anaconda-addon bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4772


Note You need to log in before you can comment on or make changes to this bug.