Bug 184396 - Error message on plugging out USB mouse or USB keyboard
Error message on plugging out USB mouse or USB keyboard
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks: 176344 198694
  Show dependency treegraph
 
Reported: 2006-03-08 10:18 EST by Raghavendra Biligiri
Modified: 2010-10-22 00:23 EDT (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2007-0304
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-07 20:41:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch that fixes this defect. (949 bytes, patch)
2006-03-08 10:18 EST, Raghavendra Biligiri
no flags Details | Diff
Candidate #1 - slighly fixed up for spaces and comments (1.05 KB, patch)
2006-04-06 03:19 EDT, Pete Zaitcev
no flags Details | Diff

  None (edit)
Description Raghavendra Biligiri 2006-03-08 10:18:15 EST
Description of problem:
On RHEL4-U3-B3(2.6.9-29) when we plug out a USB Mouse the following warning 
messages are displayed in /var/log/messages on PE2800.

    drivers/usb/input/hid-core.c : input irq status -71 received
    drivers/usb/input/hid-core.c : input irq status -71 received
    drivers/usb/input/hid-core.c : input irq status -71 received 



Version-Release number of selected component (if applicable):
RHEL4-U3-B3(2.6.9-29)

How reproducible:
Always

Steps to Reproduce:
1.Install RHEL4-U3-B3(2.6.9-29)
2.Plug-in and plug-out USB keyboard or USB mouse at the front ports.
3.Check /var/log/messages
  
Actual results:
Above warning messages are displayed in /var/log/messages

Expected results:
Above warning messages should not be displayed in /var/log/messages

Additional info:Patch that fixes this defect is attached.This patch has been 
tested at Dell and it fixes this issue.
Comment 1 Raghavendra Biligiri 2006-03-08 10:18:15 EST
Created attachment 125806 [details]
Patch that fixes this defect.
Comment 2 Raghavendra Biligiri 2006-03-08 10:32:30 EST
This issue is seen with RHEL4 U3 GA(kernel-2.6.9-34) as well.
Comment 3 Pete Zaitcev 2006-03-08 12:03:46 EST
The patch looks sensible, thanks. I have to consider its impact on
other types of equipment and perhaps take it unchanged, or request
another round of testing, depending.

I have an important question: Does the keyboard continue to work
after the messages were seen?
Comment 4 Raghavendra Biligiri 2006-03-09 02:00:31 EST
USB keyboard/mouse continues to work even after the messages are 
seen.Functionality of USB keyboard/mouse is not affected in any way.
Comment 5 Raghavendra Biligiri 2006-03-29 09:43:52 EST
Can RedHat confirm that the patch submitted will be commited into RHEL4 U4 ?
Comment 7 Pete Zaitcev 2006-04-06 03:16:41 EDT
From reading the report, I somehow imagined that this was a regression,
but actually U2 behaves in exactly the same way. If anything, bug 167070
did not go far enough fixing this.

I reviewed and tested the patch, it appears sensible and seems to work well.
Comment 8 Pete Zaitcev 2006-04-06 03:19:59 EDT
Created attachment 127393 [details]
Candidate #1 - slighly fixed up for spaces and comments
Comment 9 Pete Zaitcev 2006-05-15 18:55:16 EDT
This needs to be on the Proposed list, or else it won't make into an update.
Adding to Proposed list for consideration by PM.
Comment 10 Raghavendra Biligiri 2006-06-08 07:25:55 EDT
Patch not applied in kernel-2.6.9-39.
Comment 11 Charles Rose 2006-09-06 00:12:05 EDT
This did not make it to RHEL4.4
Comment 12 Issue Tracker 2006-09-06 14:53:30 EDT
Please add this simple fix to 4.5 which will improve usb device connection
usage and reduce unnecessary customer support calls from these  messages
being printed on the console. 


This event sent from IssueTracker by sbenjamin 
 issue 89965
Comment 15 Samuel Benjamin 2006-09-27 18:36:35 EDT
Patch defined. Requesting DEV and QE ACKS. This issue is on Dell's watch list
for 4.5.
Comment 16 Samuel Benjamin 2006-10-27 15:21:21 EDT
Raising exception and requesting ACKS for 4.5. Patch is defined. This issue is
on Dell's weekly watch list for 4.5.
Comment 19 Peter Martuccelli 2006-11-29 14:59:01 EST
Pete see if you can resolve this in time for R4.5.

Comment 20 Jay Turner 2006-12-07 14:19:16 EST
QE ack for RHEL4.5.
Comment 21 Jason Baron 2006-12-11 17:11:07 EST
committed in stream U5 build 42.30. A test kernel with this patch is available
from http://people.redhat.com/~jbaron/rhel4/
Comment 23 Raghavendra Biligiri 2006-12-15 02:18:33 EST
Issue is not reproducible with the test kernel(kernel-2.6.9-42.32.EL).
Comment 25 Mike Gahagan 2007-04-04 14:19:28 EDT
I don't appear to have a system that reproduces the original problem but I can
verify the patch is in the -52 kernel.
Comment 26 Raghavendra Biligiri 2007-04-12 06:34:24 EDT
Issue not reproducible on RHEL4.5 Snapshot5(kernel-2.6.9-51).
Comment 28 Issue Tracker 2007-04-19 17:55:29 EDT
A fix for this issue has been included in RHEL4.5. Please test the Release
Candidate of RHEL4.5, which was released today to Partners, and let us know
if the problem is resolved. The Release Candidate can be downloaded from
here:

ftp://partners.redhat.com/af38ac4316ba20df2dec5f990913396d

Internal Status set to 'Waiting on Customer'
Status set to: Waiting on Client
Resolution set to: 'RHEL 4.5'

This event sent from IssueTracker by gcase 
 issue 89965
Comment 30 Red Hat Bugzilla 2007-05-07 20:41:01 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0304.html

Note You need to log in before you can comment on or make changes to this bug.