Bug 184411 - Sound-juicer doesn't handle multiple CDs with the same DiscID correctly
Summary: Sound-juicer doesn't handle multiple CDs with the same DiscID correctly
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: sound-juicer (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Monty
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-08 16:33 UTC by John Thacker
Modified: 2013-10-20 22:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-14 15:47:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to use MBS_Rewind instead which fixes the bug (522 bytes, patch)
2006-03-08 16:33 UTC, John Thacker
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 318044 None None None Never

Description John Thacker 2006-03-08 16:33:19 UTC
Description of problem:
Some discs have the same DiscID in MusicBrainz.  A really common case is where
an identical CD was released in different countries at different times, and
MusicBrainz contains separate information with the track names and album name in
each language.  Currently, if you insert such a disc, sound-juicer pops up a
window informing you that multiple CDs match it and prompts you to select the
right one.  That's all good, but the list, rather than containing each matching
CD, contains only the first option repeated every time.  I have a patch that
fixes it.

Version-Release number of selected component (if applicable):
sound-juicer-2.13.6-1

How reproducible:
Every time

Steps to Reproduce:
1. Insert a disc whose DiscID has multiple matches in the MusicBrainz database
(http://mm.musicbrainz.org/showcdtoc.html?id=147937 is an example)
2. Observe the prompt
  
Actual results:
sound-juicer prompts one to select among a list all of which is the same, the
first listing in the database.

Expected results:
sound-juicer should prompt one to select the correct album from a list of
different choices which match those in the MusicBrainz datebase

Additional info:
I have a patch that fixes it.  A call to MBS_Back should be changed to
MBS_Rewind, since it's not clear where one will be in the MB data.  MBS_Rewind,
rather than going up one level, resets to the state immediately after the last
query.  That's what we want.  See http://www.musicbrainz.org/client_howto.html

Comment 1 John Thacker 2006-03-08 16:33:19 UTC
Created attachment 125816 [details]
Patch to use MBS_Rewind instead which fixes the bug

Comment 2 John Thacker 2006-03-08 16:34:55 UTC
I reported it upstream on an old bug that described the old behavior but was
closed when it was fixed for a time before breaking again.  Gnome bug 318044. 
It hasn't been fixed in CVS yet, but it might well be.

Comment 3 John Thacker 2006-03-14 15:47:48 UTC
Fixed upstream and now in Rawhide with the 2.14.0 release.


Note You need to log in before you can comment on or make changes to this bug.