Bug 184412 - anaconda traceback in isValidXFS
anaconda traceback in isValidXFS
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-08 11:34 EST by Karsten Hopp
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-09 11:08:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda traceback (39.98 KB, text/plain)
2006-03-08 11:34 EST, Karsten Hopp
no flags Details
new traceback (52.75 KB, text/plain)
2006-03-09 06:18 EST, Karsten Hopp
no flags Details

  None (edit)
Description Karsten Hopp 2006-03-08 11:34:29 EST
Description of problem:
anaconda-11.0.1-1 tracebacked during an installation on an OpenPower-720
machine. I'm using vscsi to an AIX host, the logical volumes have been newly
created.

Logfile attached...
Comment 1 Karsten Hopp 2006-03-08 11:34:30 EST
Created attachment 125817 [details]
anaconda traceback
Comment 2 Paul Nasrat 2006-03-08 11:43:09 EST
Manoj - can you replicate this with a box with AIX VIO here? 
Karten:

How did you create the vscsi devices?

If you switch to tty2 can you get parted /dev/sda print, if you just create a
blank partition on the vscsi drive without any volumes does it work?  Are there
any AIX error messages on the VIO server? 

Notes to self:

Is this suspect from lvm:

/dev/sda3: read failed after 0 of 2048 at 21352742912: Input/output error

16:30:02 INFO    : anaconda floppy device sda

<6>scsi0 : IBM POWER Virtual SCSI Adapter 1.5.8
<6>ibmvscsi: partner initialization complete
<6>ibmvscsi: SRP_LOGIN succeeded
<4>ibmvscsi: host srp version: 16.a, host partition IBM VIO-Server (1), OS 3,
max io 262144
<5>  Vendor: AIX       Model: VDASD             Rev:     
<5>  Type:   Direct-Access                      ANSI SCSI revision: 03
<5>SCSI device sda: 20971520 512-byte hdwr sectors (10737 MB)
<5>sda: Write Protect is off
<7>sda: Mode Sense: 17 00 00 08
<5>sda: cache data unavailable
<3>sda: assuming drive cache: write through
<5>SCSI device sda: 20971520 512-byte hdwr sectors (10737 MB)
<5>sda: Write Protect is off
<7>sda: Mode Sense: 17 00 00 08
<5>sda: cache data unavailable
<3>sda: assuming drive cache: write through
<6> sda: sda1 sda2 sda3
Comment 3 Karsten Hopp 2006-03-08 11:54:19 EST
I've created the logical volumes in AIX with
'mklv -lv vdisk0 client_rootvg 10G'
and bound them with 'mkvdev -vdev vdisk0 -vadapter vhost0 -dev vtscsi0' to the
virtual adapter vtscsi0

client_rootvg is an AIX volumegroup with 7 physical disks

How can I switch to tty2 ? I'm running anaconda inside a vterm on the HMC and
have no idea if there are other means to do that.
Comment 4 Jeremy Katz 2006-03-08 13:22:33 EST
Although you might hit other problems later (the read errors do generally mean
something else odd is going on), I went ahead and committed a change to catch
the read error in the fs checking code
Comment 5 Karsten Hopp 2006-03-09 06:17:09 EST
Now I get the usual "The partition table on device sda was unreadable..... Would
you like to initialize this drine, erasing all data ?"

It tracebacked later now, not sure when as I didn't pay attention.
I'll attach the new log.

A restart of the installation after that last traceback worked fine, though. 
It looks like there is another error condition which needs to be caught by anaconda.
Comment 6 Karsten Hopp 2006-03-09 06:18:02 EST
Created attachment 125865 [details]
new traceback
Comment 7 Jeremy Katz 2006-03-09 11:08:47 EST
lvm is trying to read and getting read errors.  Given that it's a command line
utility with no library interface, we really can't do much other than "this failed"

But it's hitting exactly the same sort of errors reading which is either a
hardware problem or a vscsi problem (could be the AIX server or the driver on
the Linux side, but I'd lean slightly towards the server piece since it is very
fragile in my experience)

Note You need to log in before you can comment on or make changes to this bug.