Bug 1844190 - Rebase sap-preconfigure, sap-netweaver-preconfigure, and sap-hana-preconfigure to 2.0.0
Summary: Rebase sap-preconfigure, sap-netweaver-preconfigure, and sap-hana-preconfigur...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: rhel-system-roles-sap
Version: ---
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Than Ngo
QA Contact: Daniel Streit
Eliane Ramos Pereira
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-04 18:33 UTC by Bernd Finger
Modified: 2020-11-04 02:27 UTC (History)
6 users (show)

Fixed In Version: rhel-system-roles-sap-2.0.0-4.el8
Doc Type: Enhancement
Doc Text:
.`_rhel-system-roles-sap_` upgraded The `_rhel-system-roles-sap_` packages have been upgraded to upstream version 2.0.0, which provides multiple bug fixes and enhancements. Notable changes include: * Improve hostname configuration and checking * Improve `uuidd` status detection and handling * Add support for the `--check (-c)` option * Increase `nofile` limits from 32800 to 65536 * Add the `nfs-utils` file to `sap_preconfigure_packages`* * Disable `firewalld`. With this change we disable `firewalld` only when it is installed. * Add minimum required versions of the `setup` package for RHEL 8.0 and RHEL 8.1. * Improve the `tmpfiles.d/sap.conf` file handling * Support single step execution or checking of SAP notes * Add the required `compat-sap-c++` packages * Improve minimum package installation handling * Detect if a reboot is required after applying the RHEL System Roles * Support setting any SElinux state. Default state is `"disabled"` * No longer fail if there is more than one line with identical IP addresses * No longer modify `/etc/hosts` if there is more than one line containing `sap_ip` * Support for HANA on RHEL 7.7 * Support for adding a repository for the IBM service and productivity tools for Power, required for SAP HANA on the `ppc64le` platform
Clone Of:
Environment:
Last Closed: 2020-11-04 02:27:48 UTC
Type: Bug
Target Upstream Version:
dstreit: needinfo+


Attachments (Terms of Use)
sap-preconfigure (21.22 KB, application/gzip)
2020-06-04 18:33 UTC, Bernd Finger
no flags Details
sap-netweaver-preconfigure (14.89 KB, application/gzip)
2020-06-04 18:34 UTC, Bernd Finger
no flags Details
sap-hana-preconfigure (21.85 KB, application/gzip)
2020-06-04 18:35 UTC, Bernd Finger
no flags Details
sap-hana-preconfigure (21.86 KB, application/gzip)
2020-06-08 09:33 UTC, Bernd Finger
no flags Details
script for creating tarballs from upstream (1.46 KB, application/x-shellscript)
2020-06-08 14:06 UTC, Bernd Finger
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4612 0 None None None 2020-11-04 02:27:53 UTC

Description Bernd Finger 2020-06-04 18:33:54 UTC
Created attachment 1695268 [details]
sap-preconfigure

Created attachment 1695268 [details]
sap-preconfigure

Created attachment 1695268 [details]
sap-preconfigure

Description of problem:
We need to build a new version based on upstream version 2.0.0, without any code which is not relevant for RHEL 7 and RHEL 8.

Version-Release number of selected component (if applicable):
2.0.0

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
The attached tar files only contain code which is relevant for RHEL 7 and RHEL 8.

Comment 1 Bernd Finger 2020-06-04 18:34:37 UTC
Created attachment 1695269 [details]
sap-netweaver-preconfigure

Comment 2 Bernd Finger 2020-06-04 18:35:01 UTC
Created attachment 1695270 [details]
sap-hana-preconfigure

Comment 3 Irina Gulina 2020-06-05 08:01:50 UTC
Please don't sign BZes with an empty comment #0


The attached playbook failed for me with 

TASK [sap-preconfigure : Verify that the DNS domain is set] ***********************************
fatal: [localhost]: FAILED! => {
    "assertion": "not( (sap_domain is undefined) or (sap_domain is none) or (sap_domain | trim == '') )",
    "changed": false,
    "evaluated_to": false,
    "msg": "You need to define the variable 'sap_domain' in defaults/main.yml."
}

Comment 6 Bernd Finger 2020-06-08 09:33:05 UTC
Created attachment 1696025 [details]
sap-hana-preconfigure

Comment 7 Bernd Finger 2020-06-08 09:37:54 UTC
Discovered and fixed 3 new issues:
https://github.com/linux-system-roles/sap-hana-preconfigure/issues/92 - firewalld installation state detection not working
https://github.com/linux-system-roles/sap-hana-preconfigure/issues/90 - File /etc/init.d/boot.local should have permissions of 0755 (configure-epb.yml)
https://github.com/linux-system-roles/sap-hana-preconfigure/issues/89 - task disable-firewall.yml in 2009879_7.yml also needs single step execution support

I also provided a new version of sap-hana-preconfigure, dated 2020-06-08 09:33 UTC. Please let me know if you want me to delete the old version and/or if you would like me to provide a diff output.

Comment 8 Than Ngo 2020-06-08 13:57:07 UTC
(In reply to Bernd Finger from comment #7)
> Discovered and fixed 3 new issues:
> https://github.com/linux-system-roles/sap-hana-preconfigure/issues/92 -
> firewalld installation state detection not working
> https://github.com/linux-system-roles/sap-hana-preconfigure/issues/90 - File
> /etc/init.d/boot.local should have permissions of 0755 (configure-epb.yml)
> https://github.com/linux-system-roles/sap-hana-preconfigure/issues/89 - task
> disable-firewall.yml in 2009879_7.yml also needs single step execution
> support
> 
> I also provided a new version of sap-hana-preconfigure, dated 2020-06-08
> 09:33 UTC. Please let me know if you want me to delete the old version
> and/or if you would like me to provide a diff output.

Bernd,

i would prefer to use the tarballs from:
  https://github.com/berndfinger/sap-preconfigure/releases/download/2.0.0/sap-preconfigure.tar.gz
  https://github.com/berndfinger/sap-hana-preconfigure/releases/download/2.0.0/sap-hana-preconfigure.tar.gz
  https://github.com/berndfinger/sap-netweaver-preconfigure/releases/download/2.0.0/sap-netweaver-preconfigure.tar.gz

and add the additional fixes to the above tarballs. It prevents the error in rpmdiff in errata-tools!

It seems the tarball which are attached in bugzilla are not the same from github.

Comment 9 Bernd Finger 2020-06-08 14:05:59 UTC
The tarballs in the upstream code have all the non-RHEL-7, non-RHEL8 code in it. For the tarball I attached here, I used the script I will now attach to this bug, named create-rhel-system-roles-sap-tar.sh.
But even that one does a git pull of the latest status. Also I did not yet update the upstream tarball with the latest pull request which I used for the last tar file in here.

Comment 10 Bernd Finger 2020-06-08 14:06:58 UTC
Created attachment 1696122 [details]
script for creating tarballs from upstream

Comment 20 Bernd Finger 2020-07-03 14:03:27 UTC
I found /usr/share/ansible/roles/sap-hana-preconfigure/tasks/sapnote/1944799.yml in rhel-system-roles-sap.noarch 2.0.0-1.el8. This file is for SLES and should not be delivered in rhel-system-roles-sap. I also found it in the new version at https://brewweb.engineering.redhat.com/brew/rpminfo?rpmID=8229419 .

The script https://bugzilla.redhat.com/attachment.cgi?id=1696122 should exclude it but maybe there is a typo in it which prevents the exclusion?

Comment 21 Than Ngo 2020-07-03 14:57:53 UTC
(In reply to Bernd Finger from comment #20)
> I found
> /usr/share/ansible/roles/sap-hana-preconfigure/tasks/sapnote/1944799.yml in
> rhel-system-roles-sap.noarch 2.0.0-1.el8. This file is for SLES and should
> not be delivered in rhel-system-roles-sap. I also found it in the new
> version at https://brewweb.engineering.redhat.com/brew/rpminfo?rpmID=8229419
> .
> 
> The script https://bugzilla.redhat.com/attachment.cgi?id=1696122 should
> exclude it but maybe there is a typo in it which prevents the exclusion?

yes, it's a typo bug in script. This issue is now fixed in rhel-system-roles-sap-2.0.0-3.el8.
Bernd, thank for checking!

Comment 34 errata-xmlrpc 2020-11-04 02:27:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (rhel-system-roles-sap bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4612


Note You need to log in before you can comment on or make changes to this bug.