Bug 1844247 - [4.5] [UI] BMH Actions / ‘Power Off’ still seen during phased reboot when host is already powered off with annotation
Summary: [4.5] [UI] BMH Actions / ‘Power Off’ still seen during phased reboot when hos...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Metal3 Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Yadan Pei
QA Contact: Yanping Zhang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-04 20:54 UTC by mlammon
Modified: 2020-10-27 16:05 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:05:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:05:49 UTC

Description mlammon 2020-06-04 20:54:55 UTC
Description of problem:
[4.5] [UI] BMH Actions / ‘Power Off’ still seen during phased reboot when host is already powered off with annotation


How reproducible:
100%

Steps to Reproduce:
1. Deploy cluster OCP 4.5
2. Login UI console and select Compute -> Bare Metal Host
3. Click on worker node <openshift-worker-0-0>
4. Click under actions/ edit annotation
5. Click add more and you will have ability to add KEY and VALUE
6. Add "reboot.metal3.io/anydata" in KEY only.  Note:  anydata can be any string

7.  This invokes the BMO Reboot "Phased Reboot".  Phased Reboot will bring host down
and remain down until the annotation is deleted from host.

Actual results:

After we see the host go down, I check on the very right
Compute->BMH-> 3 dots and still found "Power Off" in the drop down list.
This relates to https://bugzilla.redhat.com/show_bug.cgi?id=1844238
My best guess is it would have "Power On" if above bug is resolved 

Expected results:
This bug should address "phased" reboot feature.  I would think we would
not want either "Power Off or Power On" available.  Perhaps can be either
removed or tied directly to a new button but either way the workflow is broken IMO.

Additional info:

[root@sealusa6 ~]# oc get bmh openshift-worker-0-0 -n openshift-machine-api -oyaml|grep poweredOn
      Xeon(R) CPU E5-2630 v4 @ 2.20GHz","clockMegahertz":2199.996,"flags":["3dnowprefetch","abm","adx","aes","apic","arat","arch_capabilities","arch_perfmon","avx","avx2","bmi1","bmi2","clflush","cmov","constant_tsc","cpuid","cpuid_fault","cx16","cx8","de","ept","erms","f16c","flexpriority","fma","fpu","fsgsbase","fxsr","hle","hypervisor","invpcid","invpcid_single","lahf_lm","lm","mca","mce","mmx","movbe","msr","mtrr","nopl","nx","pae","pat","pcid","pclmulqdq","pdpe1gb","pge","pni","popcnt","pse","pse36","pti","rdrand","rdseed","rdtscp","rep_good","rtm","sep","smap","smep","ss","sse","sse2","sse4_1","sse4_2","ssse3","syscall","tpr_shadow","tsc","tsc_adjust","tsc_deadline_timer","tsc_known_freq","umip","vme","vmx","vnmi","vpid","x2apic","xsave","xsaveopt","xtopology"],"count":8},"hostname":"worker-0-0"},"provisioning":{"state":"provisioned","ID":"67d16dfc-9417-4284-ae5c-b4f2c12b0d74","image":{"url":"http://172.22.0.3:6180/images/rhcos-45.81.202005200134-0-openstack.x86_64.qcow2/rhcos-45.81.202005200134-0-compressed.x86_64.qcow2","checksum":"http://172.22.0.3:6180/images/rhcos-45.81.202005200134-0-openstack.x86_64.qcow2/rhcos-45.81.202005200134-0-compressed.x86_64.qcow2.md5sum"}},"goodCredentials":{"credentials":{"name":"openshift-worker-0-0-bmc-secret","namespace":"openshift-machine-api"},"credentialsVersion":"24928"},"triedCredentials":{"credentials":{"name":"openshift-worker-0-0-bmc-secret","namespace":"openshift-machine-api"},"credentialsVersion":"24928"},"errorMessage":"","poweredOn":false,"operationHistory":{"register":{"start":"2020-06-02T16:28:18Z","end":"2020-06-02T16:28:43Z"},"inspect":{"start":"2020-06-02T16:28:43Z","end":"2020-06-02T16:30:25Z"},"provision":{"start":"2020-06-02T16:30:54Z","end":"2020-06-02T16:33:37Z"},"deprovision":{"start":null,"end":null}}}'
        f:poweredOn: {}
  poweredOn: false

Version:

4.5.0-0.nightly-2020-06-01-111748

Comment 1 Andrew Beekhof 2020-06-10 12:13:37 UTC
Seems reasonable that the "power off" button should be disabled if the host is off

Comment 2 Stephen Cuppett 2020-06-10 15:54:03 UTC
This is not a blocker for 4.5.0 GA. Setting target release to current development branch (4.6.0). For fixes (if any) requested/required on earlier versions, clones will be created for 4.5.z or earlier as appropriate.

Comment 4 Tomas Jelinek 2020-07-08 05:50:53 UTC
already has been triaged so just marking as such

Comment 5 Rastislav Wagner 2020-09-17 08:14:23 UTC
Will be fixed when https://bugzilla.redhat.com/show_bug.cgi?id=1844238 merges

Comment 9 errata-xmlrpc 2020-10-27 16:05:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.