Bug 1844354 - oc set probe doesn't support setting start probes
Summary: oc set probe doesn't support setting start probes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Jan Chaloupka
QA Contact: zhou ying
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-05 07:57 UTC by Chet Hosey
Modified: 2020-10-27 16:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: oc set probe extended with ability to set startup probes Reason: upstream added support for startup probes, yet the ability to work with it was not added to oc Result: oc set probe now allows to set startup probes
Clone Of:
Environment:
Last Closed: 2020-10-27 16:05:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift oc pull 459 0 None closed bug 1844354: oc set probe: add support for startup probe 2020-10-28 18:54:52 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:05:49 UTC

Description Chet Hosey 2020-06-05 07:57:03 UTC
Description of problem:

`oc set probe` doesn't support setting startup probes. It supports liveness and readiness checks, but not startup probes.

Version-Release number of selected component (if applicable):

Checked with `oc` 4.3.23-202005230952-4fb2d4d and 4.4.0-202005290638-1960dd7:

$ oc version
Client Version: 4.3.23-202005230952-4fb2d4d
Server Version: 4.3.18
Kubernetes Version: v1.16.2

How reproducible:

100%

Steps to Reproduce:

1. run oc set probe --help

Actual results:

No flag for setting start probes.

Expected results:

Command should support --startup or similar flag.

Additional info:

Startup probes were introduced with Kubernetes 1.16, included in OCP 4.3.

Comment 3 zhou ying 2020-06-23 06:20:08 UTC
checked with  oc version --client -o yaml 
clientVersion:
  buildDate: "2020-06-22T17:36:51Z"
  compiler: gc
  gitCommit: b644a4b43e8d1cd9fa003e7686ce19454f456d08
  gitTreeState: clean
  gitVersion: 4.6.0-202006221729.p0-b644a4b
  goVersion: go1.13.4
  major: ""
  minor: ""
  platform: linux/amd64

The issue has fixed;

[zhouying@dhcp-140-138 ~]$ oc set probe -h
Set or remove a liveness, readiness or startup probe from a pod or pod template
.....

 # Set an HTTP startup probe for port 8080 and path /healthz over HTTP on the pod IP
  oc set probe dc/webapp --startup --get-url=http://:8080/healthz

      --startup=false: Set or remove a startup probe to verify this container is running

[zhouying@dhcp-140-138 ~]$ oc set probe deploy/mytest --startup --get-url=http://:8081/healthz
deployment.apps/mytest probes updated
[zhouying@dhcp-140-138 ~]$ oc get deploy/mytest -o yaml
....
        startupProbe:
          failureThreshold: 3
          httpGet:
            path: /healthz
            port: 8081
            scheme: HTTP

Comment 5 errata-xmlrpc 2020-10-27 16:05:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.