Bug 1844384 - 4.5: OpenStack: keepalive health check only fails on connection errors, not non-200 http rc
Summary: 4.5: OpenStack: keepalive health check only fails on connection errors, not n...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Machine Config Operator
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.5.0
Assignee: Yossi Boaron
QA Contact: David Sanz
URL:
Whiteboard:
: 1843498 1844064 1844446 1873401 (view as bug list)
Depends On: 1844387 1873401
Blocks: 1844446
TreeView+ depends on / blocked
 
Reported: 2020-06-05 09:46 UTC by Stefan Schimanski
Modified: 2020-08-28 18:20 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1844387 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:43:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift machine-config-operator pull 1787 None closed [release-4.5] Bug 1844384: Fail healthz/readyz curls on non-200 http errors 2020-08-28 15:40:02 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:43:46 UTC

Description Stefan Schimanski 2020-06-05 09:46:32 UTC
Description of problem:

OpenStack keepalive health check only fails on connection errors:

  https://github.com/openshift/machine-config-operator/blame/master/templates/master/00-master/openstack/files/openstack-keepalived-keepalived.yaml#L6

Background: `curl -s` does not fail on non-200 errors with successful tcp connect.

Comment 1 Antonio Murdaca 2020-06-05 09:53:18 UTC
Moving to the openstack owners

Comment 2 Stefan Schimanski 2020-06-05 09:58:08 UTC
*** Bug 1844064 has been marked as a duplicate of this bug. ***

Comment 3 Stefan Schimanski 2020-06-05 09:59:01 UTC
*** Bug 1843498 has been marked as a duplicate of this bug. ***

Comment 4 Stefan Schimanski 2020-06-05 12:54:26 UTC
*** Bug 1844446 has been marked as a duplicate of this bug. ***

Comment 7 David Sanz 2020-06-19 09:12:31 UTC
Verified that no failure is introduced with this change on 4.5.0-0.nightly-2020-06-18-210518

Comment 8 errata-xmlrpc 2020-07-13 17:43:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409

Comment 9 Kirsten Garrison 2020-08-28 18:20:26 UTC
*** Bug 1873401 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.