Bug 1844448 - etcd-operator continuously logs benign but scary gRPC connection log messages
Summary: etcd-operator continuously logs benign but scary gRPC connection log messages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.6.0
Assignee: Dan Mace
QA Contact: ge liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-05 12:41 UTC by Dan Mace
Modified: 2020-10-27 16:05 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:05:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:05:49 UTC

Description Dan Mace 2020-06-05 12:41:11 UTC
Description of problem:

The etcd-operator continuously logs connection messages like

I0604 15:21:55.493469       1 endpoint.go:68] ccResolverWrapper: sending new addresses to cc: [{https://10.0.0.4:2379  <nil> 0 <nil>}]
I0604 15:21:55.496008       1 controlbuf.go:508] transport: loopyWriter.run returning. connection error: desc = "transport is closing"
I0604 15:21:55.496107       1 controlbuf.go:508] transport: loopyWriter.run returning. connection error: desc = "transport is closing"
I0604 15:21:55.499193       1 client.go:360] parsed scheme: "endpoint"

These messages are not indicative of any problem we care about, and are also associated with internal gRPC client metrics we could extract if we wanted to know about them. As it stands, the messages fill up the logs and cause confusion and should be suppressed.

Version-Release number of selected component (if applicable):

4.4+

How reproducible:

Launch a new cluster, look at etcd-operator logs.

Actual results:

Log spam as described.

Expected results:

Blissful silence in the steady state.

Additional info:

Comment 5 errata-xmlrpc 2020-10-27 16:05:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.